summaryrefslogtreecommitdiffstats
path: root/examples/linguist/arrowpad/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/linguist/arrowpad/CMakeLists.txt')
-rw-r--r--examples/linguist/arrowpad/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/examples/linguist/arrowpad/CMakeLists.txt b/examples/linguist/arrowpad/CMakeLists.txt
new file mode 100644
index 000000000..4781947e2
--- /dev/null
+++ b/examples/linguist/arrowpad/CMakeLists.txt
@@ -0,0 +1,37 @@
+# Generated from arrowpad.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(arrowpad LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/linguist/arrowpad")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS Widgets)
+
+add_qt_gui_executable(arrowpad
+ arrowpad.cpp arrowpad.h
+ main.cpp
+ mainwindow.cpp mainwindow.h
+)
+target_link_libraries(arrowpad PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::Widgets
+)
+
+install(TARGETS arrowpad
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)