summaryrefslogtreecommitdiffstats
path: root/examples/linguist/hellotr/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/linguist/hellotr/CMakeLists.txt')
-rw-r--r--examples/linguist/hellotr/CMakeLists.txt15
1 files changed, 5 insertions, 10 deletions
diff --git a/examples/linguist/hellotr/CMakeLists.txt b/examples/linguist/hellotr/CMakeLists.txt
index 9f9fb085d..eee4edadd 100644
--- a/examples/linguist/hellotr/CMakeLists.txt
+++ b/examples/linguist/hellotr/CMakeLists.txt
@@ -1,23 +1,16 @@
-# Generated from hellotr.pro.
-
cmake_minimum_required(VERSION 3.16)
project(hellotr LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/linguist/hellotr")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Widgets)
+
#! [0]
find_package(Qt6 REQUIRED COMPONENTS LinguistTools)
#! [0]
@@ -25,6 +18,7 @@ find_package(Qt6 REQUIRED COMPONENTS LinguistTools)
qt_add_executable(hellotr
main.cpp
)
+
#! [1]
qt6_add_translations(hellotr
TS_FILES hellotr_la.ts
@@ -35,6 +29,7 @@ set_target_properties(hellotr PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(hellotr PUBLIC
Qt::Core
Qt::Gui