summaryrefslogtreecommitdiffstats
path: root/src/designer/src/designer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/designer/src/designer/CMakeLists.txt')
-rw-r--r--src/designer/src/designer/CMakeLists.txt57
1 files changed, 44 insertions, 13 deletions
diff --git a/src/designer/src/designer/CMakeLists.txt b/src/designer/src/designer/CMakeLists.txt
index be0ea16f1..cc938f58d 100644
--- a/src/designer/src/designer/CMakeLists.txt
+++ b/src/designer/src/designer/CMakeLists.txt
@@ -1,11 +1,10 @@
# Generated from designer.pro.
#####################################################################
-## designer Binary:
+## designer App:
#####################################################################
-qt_add_executable(designer
- GUI
+qt_internal_add_app(designer
SOURCES
../../../shared/fontpanel/fontpanel.cpp ../../../shared/fontpanel/fontpanel.h
../../../shared/qttoolbardialog/qttoolbardialog.cpp ../../../shared/qttoolbardialog/qttoolbardialog.h ../../../shared/qttoolbardialog/qttoolbardialog.ui
@@ -94,9 +93,9 @@ qt_add_resource(designer "qttoolbardialog"
${qttoolbardialog_resource_files}
)
-
-#### Keys ignored in scope 1:.:.:designer.pro:<TRUE>:
-# QMAKE_TARGET_DESCRIPTION = "Qt" "Designer"
+set_target_properties(designer PROPERTIES
+ QT_TARGET_DESCRIPTION "Qt Designer"
+)
## Scopes:
#####################################################################
@@ -111,19 +110,51 @@ qt_extend_target(designer CONDITION QT_CONFIG___contains___static
QT_DESIGNER_STATIC
)
-#### Keys ignored in scope 4:.:.:designer.pro:WIN32:
-# RC_ICONS = "designer.ico"
-# VERSION = "$${QT_VERSION}.0"
+if(WIN32)
+ set_target_properties(designer PROPERTIES
+ QT_TARGET_RC_ICONS "${CMAKE_CURRENT_SOURCE_DIR}/designer.ico"
+ )
+endif()
+
+if(WIN32)
+ set_target_properties(designer PROPERTIES
+ QT_TARGET_VERSION "${PROJECT_VERSION}.0"
+ )
+endif()
+
+if(UNIX)
+ set_target_properties(designer PROPERTIES
+ QT_TARGET_VERSION "${PROJECT_VERSION}"
+ )
+endif()
-#### Keys ignored in scope 5:.:.:designer.pro:else:
-# VERSION = "$${QT_VERSION}"
+if(APPLE)
+ set_target_properties(designer PROPERTIES
+ MACOSX_BUNDLE_INFO_PLIST "${CMAKE_CURRENT_SOURCE_DIR}/Info_mac.plist"
+ MACOSX_BUNDLE TRUE
+ MACOSX_BUNDLE_ICON_FILE "designer.icns"
+ OUTPUT_NAME "Designer"
+ )
+ set_source_files_properties(designer.icns PROPERTIES
+ MACOSX_PACKAGE_LOCATION Resources
+ )
+ target_sources(designer PRIVATE
+ designer.icns
+ )
+ # special case end
+ # Set values to be replaced in the custom Info_mac.plist.
+ # Also package the uifile.icns.
+ set(ICON "designer.icns")
+ set(EXECUTABLE "Designer")
+ set_source_files_properties(uifile.icns PROPERTIES MACOSX_PACKAGE_LOCATION Resources)
+ target_sources(designer PRIVATE uifile.icns)
+ # special case end
+endif()
#### Keys ignored in scope 6:.:.:designer.pro:APPLE:
# FILETYPES.files = "uifile.icns"
# FILETYPES.path = "Contents/Resources"
-# ICON = "designer.icns"
# QMAKE_BUNDLE_DATA = "FILETYPES"
-# QMAKE_INFO_PLIST = "Info_mac.plist"
qt_extend_target(designer CONDITION UNIX AND NOT HAIKU AND NOT MACOS
PUBLIC_LIBRARIES