summaryrefslogtreecommitdiffstats
path: root/src/designer/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/designer/src/lib/CMakeLists.txt')
-rw-r--r--src/designer/src/lib/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/designer/src/lib/CMakeLists.txt b/src/designer/src/lib/CMakeLists.txt
index 323e190be..24df4582a 100644
--- a/src/designer/src/lib/CMakeLists.txt
+++ b/src/designer/src/lib/CMakeLists.txt
@@ -170,6 +170,10 @@ qt_add_module(Designer
Qt::UiPlugin
Qt::Widgets
Qt::Xml
+ PRIVATE_MODULE_INTERFACE
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::WidgetsPrivate
ENABLE_AUTOGEN_TOOLS
uic
PRECOMPILED_HEADER
@@ -444,6 +448,11 @@ qt_add_resource(Designer "shared"
## Scopes:
#####################################################################
+qt_extend_target(Designer CONDITION TARGET Qt::OpenGLWidgets
+ PUBLIC_LIBRARIES
+ Qt::OpenGLWidgets
+)
+
qt_extend_target(Designer CONDITION static
DEFINES
QT_DESIGNER_STATIC
@@ -556,3 +565,8 @@ qt_extend_target(Designer CONDITION QT_BUILD_SHARED_LIBS
INCLUDE_DIRECTORIES
../../../shared/qtpropertybrowser
)
+
+qt_extend_target(Designer CONDITION QT_FEATURE_opengl
+ LIBRARIES
+ Qt::OpenGL
+)