aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMÃ¥rten Nordheim <marten.nordheim@qt.io>2020-04-30 13:33:26 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-05-12 13:14:13 +0200
commitf8db8d979afc38215f9bbfc3daaf75cfd61b5f1d (patch)
treef83922c165fa72a5e16485dc4806b1916aad8619 /CMakeLists.txt
parentec0a7a4a699b8d5575de765c1a2cd077e412a9b4 (diff)
Initial CMake port of QtVirtualKeyboard
This port makes sure that all the features that are currently tested in the CI are complete and that the tests pass. lipi-toolkit can't be tested since it's currently broken in qmake. Myscript wasn't tested as it is also not tested in coin and the SDK is not available. T9Write wasn't tested as the SDK is not avaialble. Removed outdated src/virtualkeyboard/styles/styles.pro. The styles seem to be in src/styles now. Change-Id: Ibba41d592c51a19dee63840c02a945ec7b1d721e Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 00000000..df071cba
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Generated from qtvirtualkeyboard.pro.
+
+cmake_minimum_required(VERSION 3.15.0)
+
+include(.cmake.conf)
+project(QtVirtualKeyboard
+ VERSION "${QT_REPO_MODULE_VERSION}"
+ DESCRIPTION "Qt VirtualKeyboard Libraries"
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Qml QmlTools Quick Svg) # special case
+find_package(Qt6 ${PROJECT_VERSION} CONFIG COMPONENTS BuildInternals QuickTest) # special case
+
+if(NOT TARGET Qt::Quick)
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::Quick\" is not met.")
+ return()
+endif()
+if(NOT TARGET Qt::Svg)
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::Svg\" is not met.")
+ return()
+endif()
+if(WINRT)
+ message(NOTICE "Skipping the build as the condition \"NOT WINRT\" is not met.")
+ return()
+endif()
+qt_build_repo()