summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPier Luigi Fiorini <pierluigi.fiorini@liri.io>2019-07-24 23:40:55 +0200
committerPier Luigi Fiorini <pierluigi.fiorini@liri.io>2019-07-25 11:01:34 +0200
commitf4636b934f90b2a07b09f1925a86440cf1944d08 (patch)
tree18126ba3bd78a0233d97c1403a556ecc42883ed2
parent11a726d88672b43bef6d360bebfbe79257e97b09 (diff)
Fix use of private dependency
With 0761173a, Linux SPI Accessibility bridge was added to the Wayland QPA plugin, but this had a bad side-effect to QtWaylandClient. Linux Accessibility support is a private module, this means we have to link to it with QT_PRIVATE not QT, otherwise CMake and pkg-config files for Qt5WaylandClient will depend on it. Change-Id: I6182267f97adc2cd5bd66895df148a6a45614f45 Fixes: QTBUG-76042 Reviewed-by: Frederik Gladhorn <frederik.gladhorn@qt.io>
-rw-r--r--src/client/client.pro2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/client/client.pro b/src/client/client.pro
index db91bd69..4233ac95 100644
--- a/src/client/client.pro
+++ b/src/client/client.pro
@@ -20,7 +20,7 @@ qtConfig(xkbcommon) {
}
qtHaveModule(linuxaccessibility_support_private): \
- QT += linuxaccessibility_support_private
+ QT_PRIVATE += linuxaccessibility_support_private
QMAKE_USE += wayland-client