summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLiang Qi <liang.qi@qt.io>2020-06-16 08:50:58 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-06-16 10:45:07 +0200
commit1f37019fd5156ed139108c83b34e12d34d140ac8 (patch)
treee1da2a2bf976ea00298ec36ff43011bd72f987d7 /CMakeLists.txt
parent0de4445ee106948645979d24794e55068aca5e03 (diff)
Update dependencies on 'dev' in qt/qtwayland
Remove FontDatabaseSupportPrivate/fontdatabase_support-private in the libraries dependency. The libraries were removed in qtbase in 6be9830d865be32f224e15d13ddefd9c7e176553 and the functionality is now in QtGui. Remove PlatformCompositorSupport mentions, it was removed in qtbase in 7172b5112e5dbf0cb63dec68d2f916a323748aa1, and functionality moved to QtGui. Add explicit package dependency on OpenGL, in case if qtdeclarative modules are missing, so that qtwayland can still be built without qtdeclarative. Change-Id: I5e8ec4cddd293e52c288ba629e6ba954c689a803 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 73997c03c..e1a32a252 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,14 +34,13 @@ endif()
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS
Core
Gui
+ OpenGL
)
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
EglSupport
GlxSupport
LinuxAccessibilitySupport
- FontDatabaseSupport
- PlatformCompositorSupport
Quick
ServiceSupport
XkbCommonSupport