summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-06-03 10:58:02 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-06-03 11:53:32 +0200
commitc6c174dffc0a4d991c5cdb0fbbd05e4f2209e4c5 (patch)
treeec6388e1c295dfaac6ed5e7d486a5dc0df86d564 /CMakeLists.txt
parent671220bd9bccb99de5bfe32d23264608161dadc9 (diff)
CMake: Adapt to FontDatabaseSupport not existing on macOS
In qtbase as a result of the a97a8fcc1a9b832fee2ed0e01258e1664a3e3e69 and ce2bc0e2d5b1d647db1e1726ecd434cc8a55accf changes, fontdatabasesupport is not built on macOS anymore. So it's an optional package for wayland now. Change-Id: I4ddd35fa0ec35c91ff92197189f61d4a36e126d5 Reviewed-by: Liang Qi <liang.qi@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 016803500..96d72739d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,6 @@ find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS
Core
Gui
EventDispatcherSupport
- FontDatabaseSupport
ThemeSupport
)
@@ -34,6 +33,7 @@ find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
EglSupport
GlxSupport
LinuxAccessibilitySupport
+ FontDatabaseSupport
PlatformCompositorSupport
Quick
ServiceSupport