summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-24 16:23:53 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-26 09:57:22 +0000
commite4cb32970cc1111d7bce95293e6766a879a6b5f7 (patch)
treec637be5f9e9a654c949dc2ce00d60c3c97ba8f99 /CMakeLists.txt
parentb77269ff500e184237d523496e17639c94009ac8 (diff)
CMake: Regenerate and adjust projects after merge
Some of the changes that were needed - adjusted wayland macros due to changed target names for plugins - a few direct moc file includes, to get rid of compilation errors - Threads::Threads linking for a few tests - a few special cases for QT_FOR_PRIVATE handling because pro2cmake doesn't handle those correctly at the moment (they map to PRIVATE_MODULE_INTERFACE rather than PRIVATE_LIBRARIES) - just regenerating all projects Change-Id: I418ce91b1c69c7388d41eb22b94a93a9e80fa732 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a96c05ac8..3a28f3164 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,7 @@ find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
EglSupport
GlxSupport
LinuxAccessibilitySupport
+ PlatformCompositorSupport
Quick
ServiceSupport
VulkanSupport
@@ -33,8 +34,8 @@ find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
)
# special case end
-if(NOT APPLE_OSX AND (ANDROID OR NOT LINUX))
- message(NOTICE "Skipping the build as the condition \"APPLE_OSX OR LINUX\" is not met.")
+if(NOT MACOS AND NOT QNX AND (ANDROID OR NOT LINUX))
+ message(NOTICE "Skipping the build as the condition \"LINUX OR MACOS OR QNX\" is not met.")
return()
endif()
if(NOT TARGET Qt::Gui)