summaryrefslogtreecommitdiffstats
path: root/examples/wayland/server-side-decoration/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-02-14 19:42:01 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2022-02-19 14:20:44 +0000
commite7e06083700f25f998989c8d95a02989f1a323ab (patch)
treece36ffcbba593ec2b2865e2fc7f774d75a686e31 /examples/wayland/server-side-decoration/CMakeLists.txt
parent21d2d228540d792c35b117091a17faf5ab52fb75 (diff)
Improve examples CMakeLists.txt
- Remove "# generated from xyz.pro" comment from pro2cmake - Remove automatic use of CMAKE_AUTORCC - Only opt into CMAKE_AUTOUIC if .ui files are involved - Remove explicit setting of CMAKE_INCLUDE_CURRENT_DIR - Combine multiple find_package(Qt6 ... calls) - use REQUIRED COMPONENTS - sort components alphabetically - Fix wrong indentations - Use (only) one empty line after multi-line commands Change-Id: I3ce281ae1fb44c8d54ee09860ddadd3dbbdf7271 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io> (cherry picked from commit 36b4ac5206dde6859a02df0db406ebca0eda5111) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'examples/wayland/server-side-decoration/CMakeLists.txt')
-rw-r--r--examples/wayland/server-side-decoration/CMakeLists.txt15
1 files changed, 4 insertions, 11 deletions
diff --git a/examples/wayland/server-side-decoration/CMakeLists.txt b/examples/wayland/server-side-decoration/CMakeLists.txt
index 01895f425..391fd5f9c 100644
--- a/examples/wayland/server-side-decoration/CMakeLists.txt
+++ b/examples/wayland/server-side-decoration/CMakeLists.txt
@@ -1,38 +1,31 @@
-# Generated from server-side-decoration.pro.
-
cmake_minimum_required(VERSION 3.16)
project(server-side-decoration LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/wayland/server-side-decoration")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml)
qt_add_executable(server-side-decoration
main.cpp
)
+
set_target_properties(server-side-decoration PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(server-side-decoration PUBLIC
Qt::Core
Qt::Gui
Qt::Qml
)
-
# Resources:
set(server-side-decoration_resource_files
"main.qml"