summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-15 17:53:14 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-26 09:57:26 +0000
commit5fad16ac553dd6e80939a64db6ab655e55292aeb (patch)
tree2e7cb14e28a930a57ddb9a57ef1b9ef4828e152e /tests/CMakeLists.txt
parente4cb32970cc1111d7bce95293e6766a879a6b5f7 (diff)
Fix qtwaylandscanner package dependencieswip/cmake
Use the new API provided in qtbase, to register a package dependency between the client module and the QtWaylandScannerTools package. Do the same for the compositor module. Also register a dependency between the QtWaylandScannerTools package and the WaylandScanner package. Also fix the tests condition to check the correct _FOUND variable. Change-Id: Id961a365715cef2d7d0b8a54ca9000dc3890ffd7 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index abc3f851f..ce2e25819 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -5,18 +5,15 @@ if(QT_BUILD_STANDALONE_TESTS)
# Add qt_find_package calls for extra dependencies that need to be found when building
# the standalone tests here.
# special case begin
- qt_find_package(Qt6 ${PROJECT_VERSION} OPTIONAL_COMPONENTS WaylandCompositor WaylandClient QtWaylandScannerTools)
+ qt_find_package(Qt6 ${PROJECT_VERSION} OPTIONAL_COMPONENTS WaylandCompositor WaylandClient)
- if (NOT Qt6QtWaylandScannerTools_FOUND)
+ if (NOT Qt6WaylandScannerTools_FOUND)
message(WARNING "QtWaylandTests is missing required components, nothing will be built. \
Although this could be considered an error, the configuration will still pass as coin (Qt's \
continuous integration system) will fail the build if configure fails, but will still try to \
configure the module on targets that are missing dependencies.")
return()
endif()
-
- # TODO: Why do we need this? shouldn't find_package for QtWaylandScannerTools be enough?
- qt_find_package(WaylandScanner PROVIDED_TARGETS Wayland::Scanner)
# special case end
endif()
qt_build_tests()