summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-24 16:23:53 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-26 09:57:22 +0000
commite4cb32970cc1111d7bce95293e6766a879a6b5f7 (patch)
treec637be5f9e9a654c949dc2ce00d60c3c97ba8f99 /tests/CMakeLists.txt
parentb77269ff500e184237d523496e17639c94009ac8 (diff)
CMake: Regenerate and adjust projects after merge
Some of the changes that were needed - adjusted wayland macros due to changed target names for plugins - a few direct moc file includes, to get rid of compilation errors - Threads::Threads linking for a few tests - a few special cases for QT_FOR_PRIVATE handling because pro2cmake doesn't handle those correctly at the moment (they map to PRIVATE_MODULE_INTERFACE rather than PRIVATE_LIBRARIES) - just regenerating all projects Change-Id: I418ce91b1c69c7388d41eb22b94a93a9e80fa732 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 57d928bf6..abc3f851f 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,5 +1,6 @@
# Generated from tests.pro.
+qt_find_package(Threads REQUIRED) # special case
if(QT_BUILD_STANDALONE_TESTS)
# Add qt_find_package calls for extra dependencies that need to be found when building
# the standalone tests here.
@@ -18,5 +19,4 @@ if(QT_BUILD_STANDALONE_TESTS)
qt_find_package(WaylandScanner PROVIDED_TARGETS Wayland::Scanner)
# special case end
endif()
-qt_find_package(Threads REQUIRED) # special case
qt_build_tests()