summaryrefslogtreecommitdiffstats
path: root/tests/auto/client/fullscreenshellv1/CMakeLists.txt
diff options
context:
space:
mode:
authorJohan Klokkhammer Helsing <johan.helsing@qt.io>2019-09-18 17:14:44 +0200
committerJohan Helsing <johan.helsing@qt.io>2019-11-26 11:29:29 +0000
commit12058b161e5f0d6f76523dc831acc8bdbc027fec (patch)
treeee6e6bf1c2730671544ca799b7ad414abcf17646 /tests/auto/client/fullscreenshellv1/CMakeLists.txt
parentbad0b76e5a7ed73b685848a8fd6a3555b754a81a (diff)
Initial CMake port
The client, compositor, tests, plugins and examples now build. There are still a few minor issues: - The protocol source generation is a bit hacky. - The tests for checking if building CMake projects don't work anymore as they have Qt 5 specific code. They have just been commented out for now. Fixes: QTBUG-78177 Change-Id: Ie17cb05f0cdbd5b098970ce765adaeccf61a8fde Reviewed-by: Pier Luigi Fiorini <pierluigi.fiorini@liri.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Qt CMake Build Bot
Diffstat (limited to 'tests/auto/client/fullscreenshellv1/CMakeLists.txt')
-rw-r--r--tests/auto/client/fullscreenshellv1/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/tests/auto/client/fullscreenshellv1/CMakeLists.txt b/tests/auto/client/fullscreenshellv1/CMakeLists.txt
new file mode 100644
index 000000000..00348df99
--- /dev/null
+++ b/tests/auto/client/fullscreenshellv1/CMakeLists.txt
@@ -0,0 +1,38 @@
+# Generated from fullscreenshellv1.pro.
+
+#####################################################################
+## tst_client_fullscreenshellv1 Test:
+#####################################################################
+
+qt_add_test(tst_client_fullscreenshellv1
+ SOURCES
+ ../shared_old/mockcompositor.cpp ../shared_old/mockcompositor.h
+ ../shared_old/mockfullscreenshellv1.cpp ../shared_old/mockfullscreenshellv1.h
+ ../shared_old/mockinput.cpp ../shared_old/mockinput.h
+ ../shared_old/mockiviapplication.cpp ../shared_old/mockiviapplication.h
+ ../shared_old/mockoutput.cpp ../shared_old/mockoutput.h
+ ../shared_old/mocksurface.cpp ../shared_old/mocksurface.h
+ ../shared_old/mockwlshell.cpp ../shared_old/mockwlshell.h
+ ../shared_old/mockxdgshellv6.cpp ../shared_old/mockxdgshellv6.h
+ tst_fullscreenshellv1.cpp
+ INCLUDE_DIRECTORIES
+ ../shared_old
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::WaylandClientPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::WaylandClient
+ Wayland::Client
+ Wayland::Server
+ Threads::Threads # special case
+)
+
+qt6_generate_wayland_protocol_server_sources(tst_client_fullscreenshellv1
+ FILES
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../../../src/3rdparty/protocol/fullscreen-shell-unstable-v1.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../../../src/3rdparty/protocol/ivi-application.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../../../src/3rdparty/protocol/wayland.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../../../src/3rdparty/protocol/xdg-shell-unstable-v6.xml
+)