summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a96c05ac8..3a28f3164 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,7 @@ find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
EglSupport
GlxSupport
LinuxAccessibilitySupport
+ PlatformCompositorSupport
Quick
ServiceSupport
VulkanSupport
@@ -33,8 +34,8 @@ find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS
)
# special case end
-if(NOT APPLE_OSX AND (ANDROID OR NOT LINUX))
- message(NOTICE "Skipping the build as the condition \"APPLE_OSX OR LINUX\" is not met.")
+if(NOT MACOS AND NOT QNX AND (ANDROID OR NOT LINUX))
+ message(NOTICE "Skipping the build as the condition \"LINUX OR MACOS OR QNX\" is not met.")
return()
endif()
if(NOT TARGET Qt::Gui)