summaryrefslogtreecommitdiffstats
path: root/examples/wayland/custom-extension/cpp-client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/wayland/custom-extension/cpp-client/CMakeLists.txt')
-rw-r--r--examples/wayland/custom-extension/cpp-client/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/wayland/custom-extension/cpp-client/CMakeLists.txt b/examples/wayland/custom-extension/cpp-client/CMakeLists.txt
index e2afa3cf4..3cb61a54d 100644
--- a/examples/wayland/custom-extension/cpp-client/CMakeLists.txt
+++ b/examples/wayland/custom-extension/cpp-client/CMakeLists.txt
@@ -28,6 +28,10 @@ qt6_generate_wayland_protocol_client_sources(custom-extension-cpp-client
FILES
${CMAKE_CURRENT_SOURCE_DIR}/../protocol/custom.xml
)
+set_target_properties(custom-extension-cpp-client PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
target_link_libraries(custom-extension-cpp-client PUBLIC
Qt::Core
Qt::Gui