summaryrefslogtreecommitdiffstats
path: root/examples/wayland/custom-shell/client-plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/wayland/custom-shell/client-plugin/CMakeLists.txt')
-rw-r--r--examples/wayland/custom-shell/client-plugin/CMakeLists.txt10
1 files changed, 2 insertions, 8 deletions
diff --git a/examples/wayland/custom-shell/client-plugin/CMakeLists.txt b/examples/wayland/custom-shell/client-plugin/CMakeLists.txt
index 8af9aeb30..1004a664e 100644
--- a/examples/wayland/custom-shell/client-plugin/CMakeLists.txt
+++ b/examples/wayland/custom-shell/client-plugin/CMakeLists.txt
@@ -1,21 +1,15 @@
cmake_minimum_required(VERSION 3.14)
project(exampleshellplugin LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/wayland/custom-shell/plugins")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS WaylandClient)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui WaylandClient)
qt_add_plugin(exampleshellplugin)
target_sources(exampleshellplugin PRIVATE