summaryrefslogtreecommitdiffstats
path: root/examples/wayland/custom-shell/compositor/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/wayland/custom-shell/compositor/CMakeLists.txt')
-rw-r--r--examples/wayland/custom-shell/compositor/CMakeLists.txt18
1 files changed, 5 insertions, 13 deletions
diff --git a/examples/wayland/custom-shell/compositor/CMakeLists.txt b/examples/wayland/custom-shell/compositor/CMakeLists.txt
index aab5a5585..a6a7ced9c 100644
--- a/examples/wayland/custom-shell/compositor/CMakeLists.txt
+++ b/examples/wayland/custom-shell/compositor/CMakeLists.txt
@@ -1,24 +1,15 @@
-# Generated from compositor.pro.
-
cmake_minimum_required(VERSION 3.14)
-project(custom-shell-compositor) # special case
-
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
+project(custom-shell-compositor)
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/wayland/custom-shell/compositor")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS Gui)
-find_package(Qt6 COMPONENTS Qml)
-find_package(Qt6 COMPONENTS WaylandCompositor)
+find_package(Qt6 REQUIRED COMPONENTS Core Gui Qml WaylandCompositor)
qt_add_executable(custom-shell-compositor
exampleshell.cpp exampleshell.h
@@ -30,10 +21,12 @@ qt6_generate_wayland_protocol_server_sources(custom-shell-compositor
FILES
${CMAKE_CURRENT_SOURCE_DIR}/../protocol/example-shell.xml
)
+
set_target_properties(custom-shell-compositor PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(custom-shell-compositor PUBLIC
Qt::Core
Qt::Gui
@@ -41,7 +34,6 @@ target_link_libraries(custom-shell-compositor PUBLIC
Qt::WaylandCompositor
)
-
# Resources:
set(compositor_resource_files
"images/background.png"