summaryrefslogtreecommitdiffstats
path: root/src/imports/compositor-extensions/wlshell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/compositor-extensions/wlshell/CMakeLists.txt')
-rw-r--r--src/imports/compositor-extensions/wlshell/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/imports/compositor-extensions/wlshell/CMakeLists.txt b/src/imports/compositor-extensions/wlshell/CMakeLists.txt
new file mode 100644
index 000000000..51fd0023d
--- /dev/null
+++ b/src/imports/compositor-extensions/wlshell/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Generated from wlshell.pro.
+
+#####################################################################
+## qwaylandcompositorwlshellplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qwaylandcompositorwlshellplugin
+ URI "QtWayland.Compositor.WlShell"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QWaylandCompositorWlShellPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ qwaylandcompositorwlshellplugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::WaylandCompositor
+)
+
+#### Keys ignored in scope 1:.:.:wlshell.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtWayland/Compositor/WlShell"