summaryrefslogtreecommitdiffstats
path: root/src/imports/compositor-extensions/wlshell/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/compositor-extensions/wlshell/CMakeLists.txt')
-rw-r--r--src/imports/compositor-extensions/wlshell/CMakeLists.txt20
1 files changed, 2 insertions, 18 deletions
diff --git a/src/imports/compositor-extensions/wlshell/CMakeLists.txt b/src/imports/compositor-extensions/wlshell/CMakeLists.txt
index 0dd155e35..8987621d3 100644
--- a/src/imports/compositor-extensions/wlshell/CMakeLists.txt
+++ b/src/imports/compositor-extensions/wlshell/CMakeLists.txt
@@ -1,33 +1,17 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from wlshell.pro.
-
-#####################################################################
-## qwaylandcompositorwlshellplugin Plugin:
-#####################################################################
-
qt_internal_add_qml_module(WaylandCompositorWLShell
URI "QtWayland.Compositor.WlShell"
VERSION "${PROJECT_VERSION}"
- CLASS_NAME QWaylandCompositorWlShellPlugin
- NO_PLUGIN_OPTIONAL
- PLUGIN_TARGET WaylandCompositorWLShell
- NO_GENERATE_PLUGIN_SOURCE
- NO_GENERATE_QMLTYPES
- INSTALL_SOURCE_QMLTYPES "plugins.qmltypes"
SOURCES
- qwaylandcompositorwlshellplugin.cpp
+ qwaylandcompositorwlshell_p.h qwaylandcompositorwlshell.cpp
LIBRARIES
Qt::Core
Qt::Gui
Qt::WaylandCompositor
NO_GENERATE_CPP_EXPORTS
+ PAST_MAJOR_VERSIONS 1
)
qt_internal_add_autogen_sync_header_dependencies(WaylandCompositorWLShell WaylandCompositor)
-
-#### Keys ignored in scope 1:.:.:wlshell.pro:<TRUE>:
-# CXX_MODULE = "qml"
-# QML_IMPORT_VERSION = "$$QT_VERSION"
-# TARGETPATH = "QtWayland/Compositor/WlShell"