summaryrefslogtreecommitdiffstats
path: root/tests/auto/client/fullscreenshellv1/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/client/fullscreenshellv1/CMakeLists.txt')
-rw-r--r--tests/auto/client/fullscreenshellv1/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/tests/auto/client/fullscreenshellv1/CMakeLists.txt b/tests/auto/client/fullscreenshellv1/CMakeLists.txt
new file mode 100644
index 000000000..00348df99
--- /dev/null
+++ b/tests/auto/client/fullscreenshellv1/CMakeLists.txt
@@ -0,0 +1,38 @@
+# Generated from fullscreenshellv1.pro.
+
+#####################################################################
+## tst_client_fullscreenshellv1 Test:
+#####################################################################
+
+qt_add_test(tst_client_fullscreenshellv1
+ SOURCES
+ ../shared_old/mockcompositor.cpp ../shared_old/mockcompositor.h
+ ../shared_old/mockfullscreenshellv1.cpp ../shared_old/mockfullscreenshellv1.h
+ ../shared_old/mockinput.cpp ../shared_old/mockinput.h
+ ../shared_old/mockiviapplication.cpp ../shared_old/mockiviapplication.h
+ ../shared_old/mockoutput.cpp ../shared_old/mockoutput.h
+ ../shared_old/mocksurface.cpp ../shared_old/mocksurface.h
+ ../shared_old/mockwlshell.cpp ../shared_old/mockwlshell.h
+ ../shared_old/mockxdgshellv6.cpp ../shared_old/mockxdgshellv6.h
+ tst_fullscreenshellv1.cpp
+ INCLUDE_DIRECTORIES
+ ../shared_old
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::WaylandClientPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::WaylandClient
+ Wayland::Client
+ Wayland::Server
+ Threads::Threads # special case
+)
+
+qt6_generate_wayland_protocol_server_sources(tst_client_fullscreenshellv1
+ FILES
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../../../src/3rdparty/protocol/fullscreen-shell-unstable-v1.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../../../src/3rdparty/protocol/ivi-application.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../../../src/3rdparty/protocol/wayland.xml
+ ${CMAKE_CURRENT_SOURCE_DIR}/../../../../src/3rdparty/protocol/xdg-shell-unstable-v6.xml
+)