aboutsummaryrefslogtreecommitdiffstats
path: root/examples/webchannel/standalone/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-03-12 17:05:31 +0100
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-03-15 11:28:28 +0100
commit892dfeeff0fd3c17cfeb3cbb887f7a80e436aa17 (patch)
tree0cab658cbe4a01a0f579d609d35c9646e6c04de9 /examples/webchannel/standalone/CMakeLists.txt
parente421f4b54d37ca6f685ba6ecbf89bd6f3fa53131 (diff)
Re-generate CMake project files
Change-Id: I7973833fa7b4000cb8f6e1a1fc0a8c560fe16a3b Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/webchannel/standalone/CMakeLists.txt')
-rw-r--r--examples/webchannel/standalone/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/examples/webchannel/standalone/CMakeLists.txt b/examples/webchannel/standalone/CMakeLists.txt
index 78977cd..ff085c5 100644
--- a/examples/webchannel/standalone/CMakeLists.txt
+++ b/examples/webchannel/standalone/CMakeLists.txt
@@ -9,7 +9,11 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples/webchannel/standalone")
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/webchannel/standalone")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
@@ -17,13 +21,17 @@ find_package(Qt6 COMPONENTS WebChannel)
find_package(Qt6 COMPONENTS Widgets)
find_package(Qt6 COMPONENTS WebSockets)
-add_qt_gui_executable(standalone
+qt_add_executable(standalone
../shared/websocketclientwrapper.cpp ../shared/websocketclientwrapper.h
../shared/websockettransport.cpp ../shared/websockettransport.h
core.h
dialog.cpp dialog.h dialog.ui
main.cpp
)
+set_target_properties(standalone PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
# special case begin
# pro2cmake generates invalid cmake syntax here
target_compile_definitions(standalone PUBLIC