aboutsummaryrefslogtreecommitdiffstats
path: root/examples/webchannel/standalone/CMakeLists.txt
diff options
context:
space:
mode:
authorJüri Valdmann <juri.valdmann@qt.io>2019-09-17 11:43:34 +0200
committerJüri Valdmann <juri.valdmann@qt.io>2019-09-23 11:45:12 +0000
commit902dfced06b73b92ae6cb9adc7a51acff0bcc936 (patch)
tree891ec1cabccf906bf9527b1a8278228185af596a /examples/webchannel/standalone/CMakeLists.txt
parentd87b0adb32e7ed1d897670b59d7ebbb7c504c75c (diff)
Add cmake support
Fixes: QTBUG-78190 Change-Id: Ibdfbcb479ce1af6370b9148516cef6f64e7c1abb Reviewed-by: Qt CMake Build Bot Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'examples/webchannel/standalone/CMakeLists.txt')
-rw-r--r--examples/webchannel/standalone/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/examples/webchannel/standalone/CMakeLists.txt b/examples/webchannel/standalone/CMakeLists.txt
new file mode 100644
index 0000000..c915378
--- /dev/null
+++ b/examples/webchannel/standalone/CMakeLists.txt
@@ -0,0 +1,45 @@
+# Generated from standalone.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(standalone LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS WebChannel)
+find_package(Qt6 COMPONENTS Widgets)
+find_package(Qt6 COMPONENTS WebSockets)
+
+add_qt_gui_executable(standalone
+ ../shared/websocketclientwrapper.cpp ../shared/websocketclientwrapper.h
+ ../shared/websockettransport.cpp ../shared/websockettransport.h
+ core.h
+ dialog.cpp dialog.h dialog.ui
+ main.cpp
+)
+# special case begin
+# pro2cmake generates invalid cmake syntax here
+target_compile_definitions(standalone PUBLIC
+ "BUILD_DIR=\"${CMAKE_CURRENT_BINARY_DIR}\""
+)
+# special case end
+target_link_libraries(standalone PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::WebChannel
+ Qt::WebSockets
+ Qt::Widgets
+)
+
+install(TARGETS standalone
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)