aboutsummaryrefslogtreecommitdiffstats
path: root/examples/webchannel/chatserver-cpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/webchannel/chatserver-cpp/CMakeLists.txt')
-rw-r--r--examples/webchannel/chatserver-cpp/CMakeLists.txt14
1 files changed, 4 insertions, 10 deletions
diff --git a/examples/webchannel/chatserver-cpp/CMakeLists.txt b/examples/webchannel/chatserver-cpp/CMakeLists.txt
index 501f10f..dfbd8dc 100644
--- a/examples/webchannel/chatserver-cpp/CMakeLists.txt
+++ b/examples/webchannel/chatserver-cpp/CMakeLists.txt
@@ -1,23 +1,15 @@
-# Generated from chatserver-cpp.pro.
-
cmake_minimum_required(VERSION 3.16)
project(chatserver LANGUAGES CXX)
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTORCC ON)
-set(CMAKE_AUTOUIC ON)
if(NOT DEFINED INSTALL_EXAMPLESDIR)
- set(INSTALL_EXAMPLESDIR "examples")
+ set(INSTALL_EXAMPLESDIR "examples")
endif()
set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/webchannel/chatserver-cpp")
-find_package(Qt6 COMPONENTS Core)
-find_package(Qt6 COMPONENTS WebSockets)
-find_package(Qt6 COMPONENTS WebChannel)
+find_package(Qt6 REQUIRED COMPONENTS Core WebChannel WebSockets)
qt_add_executable(chatserver
../shared/websocketclientwrapper.cpp ../shared/websocketclientwrapper.h
@@ -25,10 +17,12 @@ qt_add_executable(chatserver
chatserver.cpp chatserver.h
main.cpp
)
+
set_target_properties(chatserver PROPERTIES
WIN32_EXECUTABLE FALSE
MACOSX_BUNDLE TRUE
)
+
target_link_libraries(chatserver PUBLIC
Qt::Core
Qt::WebChannel