summaryrefslogtreecommitdiffstats
path: root/chromium/third_party/clang_format/script/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'chromium/third_party/clang_format/script/CMakeLists.txt')
-rw-r--r--chromium/third_party/clang_format/script/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/chromium/third_party/clang_format/script/CMakeLists.txt b/chromium/third_party/clang_format/script/CMakeLists.txt
new file mode 100644
index 00000000000..b029f712190
--- /dev/null
+++ b/chromium/third_party/clang_format/script/CMakeLists.txt
@@ -0,0 +1,21 @@
+set(LLVM_LINK_COMPONENTS support)
+
+add_clang_executable(clang-format
+ ClangFormat.cpp
+ )
+
+target_link_libraries(clang-format
+ clangBasic
+ clangFormat
+ clangLex
+ clangRewriteCore
+ clangTooling
+ )
+
+install(TARGETS clang-format RUNTIME DESTINATION bin)
+install(PROGRAMS clang-format-bbedit.applescript DESTINATION share/clang)
+install(PROGRAMS clang-format-diff.py DESTINATION share/clang)
+install(PROGRAMS clang-format-sublime.py DESTINATION share/clang)
+install(PROGRAMS clang-format.el DESTINATION share/clang)
+install(PROGRAMS clang-format.py DESTINATION share/clang)
+install(PROGRAMS git-clang-format DESTINATION bin)