summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntti Kokko <antti.kokko@qt.io>2018-10-03 11:05:01 +0300
committerJani Heikkinen <jani.heikkinen@qt.io>2018-10-10 04:25:10 +0000
commitff3de56218e1012e3b0dd056356253b105eb6f2e (patch)
tree8784e086623b871760e58e5d10056f1015da1274
parentbd274cc86dfc1d3ec6ace444f4b781589d45b75d (diff)
Add changes file for Qt 5.9.7v5.9.7
Change-Id: I841c0609e2e639b165216eb15afaba57f6211622 Reviewed-by: Michal Klocek <michal.klocek@qt.io>
-rw-r--r--dist/changes-5.9.759
1 files changed, 59 insertions, 0 deletions
diff --git a/dist/changes-5.9.7 b/dist/changes-5.9.7
new file mode 100644
index 00000000..c64098d3
--- /dev/null
+++ b/dist/changes-5.9.7
@@ -0,0 +1,59 @@
+Qt 5.9.7 is a bug-fix release. It maintains both forward and backward
+compatibility (source and binary) with Qt 5.9.0 through 5.9.6.
+
+For more details, refer to the online documentation included in this
+distribution. The documentation is also available online:
+
+http://doc.qt.io/qt-5/index.html
+
+The Qt version 5.9 series is binary compatible with the 5.8.x series.
+Applications compiled for 5.8 will continue to run with 5.9.
+
+Some of the changes listed in this file include issue tracking numbers
+corresponding to tasks in the Qt Bug Tracker:
+
+https://bugreports.qt.io/
+
+Each of these identifiers can be entered in the bug tracker to obtain more
+information about a particular change.
+
+****************************************************************************
+* Qt 5.9.7 Changes *
+****************************************************************************
+
+Chromium
+--------
+
+ - Security fixes from Chromium up to version 69.0.3497.113:
+ * CVE-2018-4117
+ * CVE-2018-6124
+ * CVE-2018-6129
+ * CVE-2018-6130
+ * CVE-2018-6132
+ * CVE-2018-6135
+ * CVE-2018-6144
+ * CVE-2018-6145
+ * CVE-2018-6153
+ * CVE-2018-6154
+ * CVE-2018-6155
+ * CVE-2018-6155
+ * CVE-2018-6156
+ * CVE-2018-6159
+ * CVE-2018-6161
+ * CVE-2018-6162
+ * CVE-2018-6165
+ * CVE-2018-16066
+ * CVE-2018-16067
+ * CVE-2018-16068
+ * CVE-2018-16076
+ * CVE-2018-16077
+
+Platform Specific Changes
+-------------------------
+
+ - macOS
+ * [QTBUG-69476] Fixed Xcode version check to work with major versions >= 10
+ * [QTBUG-70380] Build fix for building with XCode version >= 9.13
+
+ - Windows
+ * [QTBUG-69139] Worked around internal compiler error with MSVC 2017 v15.7.4