summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2021-02-11 10:03:24 +0100
committerMichal Klocek <michal.klocek@qt.io>2021-05-22 14:10:10 +0200
commit97dcbd4019456b9a1c567faddb0521b7505d80fc (patch)
tree9c77c5640b1563d853c79898cd64d87252fe8c41 /tests/CMakeLists.txt
parentdd523573f2981cc58d4da0ec6e2b061a6172a8eb (diff)
Add tests to the cmake build
Use QT_TESTCASE_SOURCEDIR instead of TESTS_SOURCE_DIR. Introduce Test::HttpServer and Test::Util targets. Query shared data location from server. Clean up "shared" resources. Note QT_TESTCASE_SOURCEDIR must be turned into the canonical form since the user can call on windows: "cmake \path\to\foo" instead of "cmake c:\path\to\foo" which will break all file:// urls. Note this patch breaks qmake builds. Task-number: QTBUG-91760 Change-Id: Ibc1f904ac9acd375d1ff70ff80f0c533497e3f20 Reviewed-by: Michael BrĂ¼ning <michael.bruning@qt.io>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 000000000..87383cc24
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,24 @@
+if(NOT QT_BUILD_STANDALONE_TESTS)
+ cmake_minimum_required(VERSION 3.18)
+
+ include(${CMAKE_CURRENT_LIST_DIR}/../.cmake.conf)
+
+ project(QtWebEngineTests
+ VERSION "${QT_REPO_MODULE_VERSION}"
+ DESCRIPTION "Qt WebEngine Tests"
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+ )
+endif()
+
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Gui Widgets
+ WebEngineCore WebEngineWidgets WebEngineQuick QuickWidgets Test QuickTest)
+
+if(NOT QT_BUILD_STANDALONE_TESTS)
+ qt_build_repo_begin()
+ qt_build_tests()
+ qt_build_repo_end()
+else()
+ qt_build_tests()
+endif()