summaryrefslogtreecommitdiffstats
path: root/tests/auto/core/CMakeLists.txt
diff options
context:
space:
mode:
authorAllan Sandfeld Jensen <allan.jensen@qt.io>2021-06-14 16:11:54 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-06-16 16:42:22 +0000
commit551b83b280bf83137e0c8ceefad59558bfe9e03e (patch)
treea3133e21416d599db2a635c9bbfec9b560516de7 /tests/auto/core/CMakeLists.txt
parent5f4fb14cb0f6b443885e79516f450853e44f650d (diff)
Stop using Widgets in WebEngineCore tests
With QWebEnginePage in Core we can now make the core tests core-only. Add the same times moves tests from widgets that only uses core classes. Change-Id: I67a25b534912d9a0891e16b0419f0db9bf434e92 Reviewed-by: Peter Varga <pvarga@inf.u-szeged.hu> (cherry picked from commit b8c48ee53009365a39d9dde1f6773048ec5ee4a0) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'tests/auto/core/CMakeLists.txt')
-rw-r--r--tests/auto/core/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/core/CMakeLists.txt b/tests/auto/core/CMakeLists.txt
index ee2f010d0..0d2340188 100644
--- a/tests/auto/core/CMakeLists.txt
+++ b/tests/auto/core/CMakeLists.txt
@@ -1,5 +1,11 @@
add_subdirectory(qwebenginecookiestore)
+add_subdirectory(qwebenginesettings)
add_subdirectory(qwebengineurlrequestinterceptor)
+add_subdirectory(origins)
+if(NOT boot2qt)
+ add_subdirectory(devtools)
+endif()
if(QT_FEATURE_ssl)
add_subdirectory(qwebengineclientcertificatestore)
+ add_subdirectory(certificateerror)
endif()