summaryrefslogtreecommitdiffstats
path: root/tests/auto/core/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Klocek <michal.klocek@qt.io>2021-02-11 10:03:24 +0100
committerMichal Klocek <michal.klocek@qt.io>2021-05-22 14:10:10 +0200
commit97dcbd4019456b9a1c567faddb0521b7505d80fc (patch)
tree9c77c5640b1563d853c79898cd64d87252fe8c41 /tests/auto/core/CMakeLists.txt
parentdd523573f2981cc58d4da0ec6e2b061a6172a8eb (diff)
Add tests to the cmake build
Use QT_TESTCASE_SOURCEDIR instead of TESTS_SOURCE_DIR. Introduce Test::HttpServer and Test::Util targets. Query shared data location from server. Clean up "shared" resources. Note QT_TESTCASE_SOURCEDIR must be turned into the canonical form since the user can call on windows: "cmake \path\to\foo" instead of "cmake c:\path\to\foo" which will break all file:// urls. Note this patch breaks qmake builds. Task-number: QTBUG-91760 Change-Id: Ibc1f904ac9acd375d1ff70ff80f0c533497e3f20 Reviewed-by: Michael BrĂ¼ning <michael.bruning@qt.io>
Diffstat (limited to 'tests/auto/core/CMakeLists.txt')
-rw-r--r--tests/auto/core/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/auto/core/CMakeLists.txt b/tests/auto/core/CMakeLists.txt
new file mode 100644
index 000000000..ee2f010d0
--- /dev/null
+++ b/tests/auto/core/CMakeLists.txt
@@ -0,0 +1,5 @@
+add_subdirectory(qwebenginecookiestore)
+add_subdirectory(qwebengineurlrequestinterceptor)
+if(QT_FEATURE_ssl)
+ add_subdirectory(qwebengineclientcertificatestore)
+endif()