summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2017-02-13 15:44:00 +0100
committerJoerg Bornemann <joerg.bornemann@qt.io>2017-02-14 17:42:39 +0000
commitaeefec9f3ff1925e9a663f1d84e44bdd0780f849 (patch)
tree10d17a8c28de789ba6327397cb0449bc4591ff71 /tools
parent1f8154cd473bf57aad59ef1c4cf7c9a3be9a823d (diff)
Fix MSVC version detection
Do not check for exactly MSVC version 14.0 but compare if the actual version is less than the requested version. Task-number: QTBUG-58826 Change-Id: I249ed3c697ccb911784a83463b1c23185c9b3856 Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@qt.io>
Diffstat (limited to 'tools')
-rw-r--r--tools/qmake/mkspecs/features/functions.prf14
1 files changed, 13 insertions, 1 deletions
diff --git a/tools/qmake/mkspecs/features/functions.prf b/tools/qmake/mkspecs/features/functions.prf
index 52bb5ec0..6545ef79 100644
--- a/tools/qmake/mkspecs/features/functions.prf
+++ b/tools/qmake/mkspecs/features/functions.prf
@@ -13,6 +13,18 @@ defineTest(isQtMinimum) {
}
}
+defineTest(isMinMSVCVersion) {
+ actual = $$split(MSVC_VER, .)
+ actual_major = $$member(actual, 0)
+ actual_minor = $$member(actual, 1)
+ requested_major = $$1
+ requested_minor = $$2
+ lessThan(actual_major, $$requested_major): return(false)
+ greaterThan(actual_major, $$requested_major): return(true)
+ lessThan(actual_minor, $$requested_minor): return(false)
+ return(true)
+}
+
defineTest(isPlatformSupported) {
QT_FOR_CONFIG += gui-private
linux {
@@ -27,7 +39,7 @@ defineTest(isPlatformSupported) {
return(false)
}
msvc {
- !equals(MSVC_VER, "14.0") {
+ !isMinMSVCVersion(14, 0) {
skipBuild("Qt WebEngine on Windows requires MSVC 2015 Update 2 or later.")
return(false)
}