summaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorAllan Sandfeld Jensen <allan.jensen@qt.io>2017-02-27 16:42:32 +0100
committerLiang Qi <liang.qi@qt.io>2017-02-27 22:34:16 +0000
commitcb6564b11ea0a81155b59ab178ff75148017a952 (patch)
tree9eafc85c097040d2a868c3c39d6064277b88f916 /tools
parent1e5ac8c491381f2ef70df6383407e9cbe226b4b9 (diff)
Block debug builds with GCC 4.8
Skia does not mark inline functions used in optional arch cpp files with always_inline, which means they can be un-inlined and end up as in the object files where the linker will pick one at random without knowing some of them are compiled with optional arch features. Task-number: QTBUG-59154 Change-Id: I8495e04550898b093ab39c4dc0f37ad6e8948864 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tools')
-rw-r--r--tools/qmake/mkspecs/features/functions.prf11
1 files changed, 9 insertions, 2 deletions
diff --git a/tools/qmake/mkspecs/features/functions.prf b/tools/qmake/mkspecs/features/functions.prf
index 35607986..a26dbed4 100644
--- a/tools/qmake/mkspecs/features/functions.prf
+++ b/tools/qmake/mkspecs/features/functions.prf
@@ -210,9 +210,16 @@ defineTest(isSanitizerLinuxClangVersionSupported) {
defineTest(isGCCVersionSupported) {
# The below will work for gcc 4.7 and up and also match gcc 5
- greaterThan(QT_GCC_MINOR_VERSION, 6):return(true)
+ CONFIG(release, debug|release): greaterThan(QT_GCC_MINOR_VERSION, 6):return(true)
greaterThan(QT_GCC_MAJOR_VERSION, 4):return(true)
- skipBuild("Using gcc version "$$QT_GCC_MAJOR_VERSION"."$$QT_GCC_MINOR_VERSION", but at least gcc version 4.7 is required to build Qt WebEngine.")
+
+ # We need GCC 4.9 for debug builds because Skia handles SIMD inlines in headers poorly.
+ greaterThan(QT_GCC_MINOR_VERSION, 8):return(true)
+ CONFIG(debug, debug|release) {
+ skipBuild("Using gcc version "$$QT_GCC_MAJOR_VERSION"."$$QT_GCC_MINOR_VERSION", but at least gcc version 4.9 is required to build debug versions of Qt WebEngine.")
+ } else {
+ skipBuild("Using gcc version "$$QT_GCC_MAJOR_VERSION"."$$QT_GCC_MINOR_VERSION", but at least gcc version 4.7 is required to build Qt WebEngine.")
+ }
return(false)
}