summaryrefslogtreecommitdiffstats
path: root/examples/webenginewidgets/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/webenginewidgets/CMakeLists.txt')
-rw-r--r--examples/webenginewidgets/CMakeLists.txt33
1 files changed, 19 insertions, 14 deletions
diff --git a/examples/webenginewidgets/CMakeLists.txt b/examples/webenginewidgets/CMakeLists.txt
index 651a01344..3ce666d72 100644
--- a/examples/webenginewidgets/CMakeLists.txt
+++ b/examples/webenginewidgets/CMakeLists.txt
@@ -1,21 +1,26 @@
-add_subdirectory(minimal)
-add_subdirectory(contentmanipulation)
-add_subdirectory(cookiebrowser)
-add_subdirectory(notifications)
-add_subdirectory(simplebrowser)
-add_subdirectory(stylesheetbrowser)
-add_subdirectory(videoplayer)
-add_subdirectory(webui)
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
+qt_internal_add_example(contentmanipulation)
+qt_internal_add_example(cookiebrowser)
+qt_internal_add_example(notifications)
+qt_internal_add_example(simplebrowser)
+qt_internal_add_example(push-notifications)
+qt_internal_add_example(videoplayer)
if(QT_FEATURE_webengine_geolocation)
- add_subdirectory(maps)
+ qt_internal_add_example(maps)
endif()
if(QT_FEATURE_webengine_webchannel)
- add_subdirectory(markdowneditor)
+ qt_internal_add_example(recipebrowser)
endif()
if(QT_FEATURE_webengine_printing_and_pdf)
- add_subdirectory(printme)
- add_subdirectory(html2pdf)
+ qt_internal_add_example(printme)
+ qt_internal_add_example(html2pdf)
endif()
-if(QT_FEATURE_webengine_spellchecker AND NOT CMAKE_CROSSCOMPILING AND NOT QT_FEATURE_webengine_native_spellchecker)
- add_subdirectory(spellchecker)
+if(QT_FEATURE_webengine_spellchecker AND NOT CMAKE_CROSSCOMPILING
+ AND NOT QT_FEATURE_webengine_native_spellchecker AND NOT WIN32)
+ qt_internal_add_example(spellchecker)
+endif()
+if(QT_FEATURE_ssl)
+ qt_internal_add_example(clientcertificate)
endif()