summaryrefslogtreecommitdiffstats
path: root/config.tests
Commit message (Collapse)AuthorAgeFilesLines
* Adaptations for Chromium 71Allan Sandfeld Jensen2019-01-281-1/+1
| | | | | | | Change-Id: Ib650113b05dfd4771240804f94e33c07aa317bf2 Reviewed-by: Michael Brüning <michael.bruning@qt.io> Reviewed-by: Peter Varga <pvarga@inf.u-szeged.hu> Reviewed-by: Jüri Valdmann <juri.valdmann@qt.io>
* Fix building tst_dialogs against libc++Jüri Valdmann2018-11-061-1/+2
| | | | | | | Linking fails if re2 was built against libstdc++. Change-Id: I69868ff284c8d23ccd7219f4da6ec750ff7674b9 Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* Merge remote-tracking branch 'origin/5.11' into 5.12Allan Sandfeld Jensen2018-09-171-3/+0
|\ | | | | | | | | | | | | | | Conflicts: src/3rdparty src/core/core_common.pri Change-Id: I36dc3a70aa653e6c8a610c787b615034180a6127
| * Remove check for catalog support in libxml2Jimi Huotari2018-08-251-3/+0
| | | | | | | | | | | | | | | | | | | | | | | | Changes have been made upstream, backported in http://code.qt.io/cgit/qt/qtwebengine-chromium.git/commit/?h=65-based&id=eb5360b2 that make it possible to link against system libxml2 again, even if it has been compiled with catalog support. Thanks to Arfrever Frehtes Taifersar Arahesis for their help on this. Change-Id: I61a49ab806f6dbbd96a2df09946c1a14062e6df5 Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* | Fix libvpx config testsThiago Macieira2018-09-061-1/+1
| | | | | | | | | | | | | | It'll never pass unless the code is valid C++. Change-Id: I8b4ab98c34b94afd94b6fffd15516ec82d79bf17 Reviewed-by: Jüri Valdmann <juri.valdmann@qt.io>
* | Update libvpx config testJüri Valdmann2018-08-291-7/+8
|/ | | | | | | | | | WebRTC requires a newer, unreleased, version of libvpx. The config test should detect it once it has been released. Until then the bundled version must be used. Task-number: QTBUG-70183 Change-Id: Ie97319d3f9560e44ebc823fc07a481696a82648e Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* Fix libvpx checkAllan Sandfeld Jensen2018-07-132-2/+3
| | | | | | | | | | | | We no longer depend on a custom configuration of libvpx and shouldn't check for non-standard headers. Also fixes bitrot in the config.test. Task-number: QTBUG-50554 Change-Id: I7b625e735536f7a79e41d036b7b8dc4d79f2262b Reviewed-by: Lisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
* Simplify libxml2 system compatibility detectionMichal Klocek2018-04-121-0/+3
| | | | | | | Test for icu also in xml2 compile test. Change-Id: I435f609761cb299f58a9b5f68e31698bb238ab1c Reviewed-by: Kai Koehne <kai.koehne@qt.io>
* Fix style in alsatestMichal Klocek2018-04-121-2/+2
| | | | | Change-Id: If35a8f3a69e21a8fbd203ca84c37efdcac514549 Reviewed-by: Kai Koehne <kai.koehne@qt.io>
* Add check for catalog support in libxml2Michal Klocek2018-04-122-0/+40
| | | | | | | | | | | | Since https://codereview.chromium.org/2788063002 libxml2 is expected to have disabled catalog support. Prevent crashes of render process and do not link against system libxml2 if it is compiled with catalog support. Task-number: QTBUG-66488 Change-Id: I2d922929878262c555802336841536eba1294db2 Reviewed-by: Kai Koehne <kai.koehne@qt.io>
* Clarify Windows build requirementsJoerg Bornemann2018-03-121-1/+1
| | | | | | | | [ChangeLog][QtWebEngine] QtWebEngine requires Visual Studio 2017. Task-number: QTBUG-66596 Change-Id: Ib9961afef17bc095bdf983cb06981e16963157c1 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* Merge remote-tracking branch 'origin/5.10' into 5.11Allan Sandfeld Jensen2018-02-151-0/+28
|\ | | | | | | Change-Id: I2169baef0a8adb5523d2cfe58896199e967ac1b7
| * Add license header5.10Kai Koehne2018-02-061-0/+28
| | | | | | | | | | | | | | Add license header to file added in commit f0c5f3306fadc. Change-Id: I4343f74857f8afdca277666a206d08d7a1167bbf Reviewed-by: Michal Klocek <michal.klocek@qt.io>
* | Merge remote-tracking branch 'origin/5.10' into devAllan Sandfeld Jensen2018-02-022-0/+15
|\ \ | |/ | | | | | | | | | | | | | | | | | | | | Conflicts: src/core/download_manager_delegate_qt.cpp src/core/download_manager_delegate_qt.h src/core/render_widget_host_view_qt.cpp src/core/web_contents_adapter.cpp src/webengine/api/qquickwebengineview.cpp tests/auto/widgets/qwebenginedownloads/tst_qwebenginedownloads.cpp Change-Id: I2308414ce257ae5bb0fc9f6493aa111a267ff39b
| * Add 32bit host compiler testMichal Klocek2018-01-242-0/+15
| | | | | | | | | | | | | | | | | | The 32bit compiler is required for creating v8 snapshots. Task-number: QTBUG-65004 Task-number: QTBUG-64869 Change-Id: I0a7a351208768f0b12900fac14d3abd5c8d99fa2 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* | Adaptations for Chromium 63Allan Sandfeld Jensen2018-01-251-2/+2
|/ | | | | Change-Id: I551c7091bbc0463bed94180313eb2bfe92f0ad84 Reviewed-by: Peter Varga <pvarga@inf.u-szeged.hu>
* Merge branch '5.9' into 5.10Allan Sandfeld Jensen2017-09-063-7/+7
|\ | | | | | | Change-Id: I9fe9946ba47f9ef509a861963c83e275a25fffd0
| * Add detection for system re2Allan Sandfeld Jensen2017-09-032-0/+38
| | | | | | | | | | | | Change-Id: Ifa305045f3594f06b0ee106cd43f9d35853f8958 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Michal Klocek <michal.klocek@qt.io>
| * Remove dead code for detecting system SRTPAllan Sandfeld Jensen2017-08-112-38/+0
| | | | | | | | | | | | | | | | | | We currently don't support unbundling SRTP because Chromium uses a too new unreleased version, but we were still testing for it and claiming to use the system one if found. Change-Id: I250f0d7fc1e09398b3196895bdd529d366cd0a86 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
* | Fix libvpx detectionPeter Varga2017-06-161-0/+5
|/ | | | | | | | | | webrtc in 58-based Chromium uses "decoder getters for the last quantizer" in libvpx. This feautre is not available in the current latest release of libvpx (1.6.1) thus add config test for the corresponding macro. Change-Id: Ib60582bc5401ce0c8960b99c4369bb373ea754d8 Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io>
* Move qmake files to standard locationsAllan Sandfeld Jensen2017-05-0212-0/+233
The tools/qmake directory is a left over from webkit where qmake was but one of many buildsystems. This is not necessary for qtwebengine, so we can instead use the standard locations. Change-Id: I3d126d6627295b113b091f3eabeee25f1c1f6183 Reviewed-by: Kai Koehne <kai.koehne@qt.io> Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@qt.io>