summaryrefslogtreecommitdiffstats
path: root/tools/qmake/mkspecs/features/functions.prf
Commit message (Expand)AuthorAgeFilesLines
* Move qmake files to standard locationsAllan Sandfeld Jensen2017-05-021-408/+0
* Make python2 usage more robustJoerg Bornemann2017-04-271-20/+19
* Remove unused qmake functions and helper scriptsJoerg Bornemann2017-04-211-33/+0
* Re-enable building with gcc 4.9.1Allan Sandfeld Jensen2017-04-041-4/+0
* Remove blacklists of old glib and gcc 4.8 debug buildsAllan Sandfeld Jensen2017-03-261-8/+6
* Merge remote-tracking branch 'origin/5.8' into 5.9Allan Sandfeld Jensen2017-03-021-1/+13
|\
| * Fix MSVC version detectionJoerg Bornemann2017-02-141-1/+13
* | Support cross-builds and alternative compilers with GNAllan Sandfeld Jensen2017-03-011-0/+19
* | Simple adaptations to Chromium 55Allan Sandfeld Jensen2017-03-011-4/+9
* | Block debug builds with GCC 4.8Allan Sandfeld Jensen2017-02-271-2/+9
* | Refactor release and debug handlingMichal Klocek2017-02-061-27/+8
* | Merge remote-tracking branch 'origin/5.8' into devLiang Qi2017-01-301-0/+5
|\ \ | |/
| * Enforce check for minimal Windows SDK versionKai Koehne2017-01-251-0/+5
* | Add gn build of qtwebengine for linuxMichal Klocek2017-01-251-5/+11
* | Add gn rebuild after bootstrapMichal Klocek2016-12-081-2/+4
* | Add gn bootstrap to build systemMichal Klocek2016-12-081-0/+19
* | Merge remote-tracking branch 'origin/5.8' into devMichael BrĂ¼ning2016-12-071-1/+1
|\ \ | |/
| * Merge remote-tracking branch 'origin/5.7' into 5.8Allan Sandfeld Jensen2016-11-251-1/+1
| |\
| | * Merge branch '5.6' into 5.7Allan Sandfeld Jensen2016-11-241-1/+1
| | |\
| | | * Check if the .git directory exists before invoking gitAndy Shaw2016-11-101-1/+1
* | | | Split ninja target into runninja and buildninja in gyp_runMichal Klocek2016-12-021-11/+12
* | | | Add support for system based ninjaMichal Klocek2016-11-301-11/+8
|/ / /
* | | Add support for compiling WebEngine with Clang sanitizer optionsAlexandru Croitor2016-11-221-0/+101
* | | Merge "Merge remote-tracking branch 'origin/5.7' into 5.8" into refs/staging/5.8Allan Sandfeld Jensen2016-11-111-0/+10
|\ \ \
| * \ \ Merge remote-tracking branch 'origin/5.7' into 5.8Liang Qi2016-11-111-0/+10
| |\ \ \ | | |/ /
| | * | Give better error on unsupported platformsAllan Sandfeld Jensen2016-10-131-0/+10
* | | | Add out of source builds for ninja bootstrapMichal Klocek2016-11-111-16/+5
|/ / /
* | | Revert "Revert "Lower minimum OS X requirements back to 10.9""Liang Qi2016-10-191-5/+5
* | | Revert "Lower minimum OS X requirements back to 10.9"Jani Heikkinen2016-10-171-5/+5
* | | Lower minimum OS X requirements back to 10.9Alexandru Croitor2016-10-121-5/+5
* | | Prepare for configure modularization in qtbaseLars Knoll2016-09-161-0/+1
* | | Restore ability to build with Qt 5.7v5.8.0-alpha1Allan Sandfeld Jensen2016-08-281-0/+15
* | | Adjust webengine to the qtConfig() changes in qtbaseLars Knoll2016-08-231-2/+2
* | | Merge remote-tracking branch 'origin/5.7' into devLiang Qi2016-08-161-0/+4
|\ \ \ | |/ /
| * | Merge remote-tracking branch 'origin/5.6' into 5.7Liang Qi2016-08-161-0/+4
| |\ \ | | |/
| | * Explicitly disable the build on MirSimon Hausmann2016-08-151-0/+4
* | | Merge remote-tracking branch 'origin/5.7' into devLiang Qi2016-08-051-7/+13
|\ \ \ | |/ /
| * | Allow building WebEngine 5.7 on OS X 10.9Alexandru Croitor2016-07-051-2/+2
| * | Fix building on OS X 10.9 with 10.10 SDKAlexandru Croitor2016-07-011-4/+6
| * | Fix python version checkJoerg Bornemann2016-06-221-5/+9
* | | Raise minimum OS X requirementsAllan Sandfeld Jensen2016-08-031-5/+5
* | | Require Windows 10 SDKAllan Sandfeld Jensen2016-06-281-0/+20
* | | Merge branch '5.7' into devAllan Sandfeld Jensen2016-06-141-9/+3
|\ \ \ | |/ /
| * | Merge remote-tracking branch 'origin/5.6' into 5.7Allan Sandfeld Jensen2016-05-311-9/+3
| |\ \ | | |/
| | * Fix 'The command line is too long' errors on WindowsKai Koehne2016-05-301-9/+3
* | | Do not try to build using MSVC 2013Allan Sandfeld Jensen2016-05-301-3/+3
|/ /
* | Make isMinOSXSDKVersion() test reusable for different versions.Alexandru Croitor2016-03-221-12/+17
* | Require OSX SDK version of at least 10.10.3.Alexandru Croitor2016-03-081-5/+25
* | Skip building on 32-bit windows hostsAllan Sandfeld Jensen2016-03-051-0/+12
* | Require xcode 7.0 and OS X 10.10Allan Sandfeld Jensen2016-02-221-5/+5
|/