summaryrefslogtreecommitdiffstats
path: root/Source/WebKit2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Source/WebKit2/CMakeLists.txt')
-rw-r--r--Source/WebKit2/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/Source/WebKit2/CMakeLists.txt b/Source/WebKit2/CMakeLists.txt
index ffff0fc55..9af82650b 100644
--- a/Source/WebKit2/CMakeLists.txt
+++ b/Source/WebKit2/CMakeLists.txt
@@ -818,10 +818,10 @@ if (ENABLE_DATABASE_PROCESS)
endif ()
endif ()
-POPULATE_LIBRARY_VERSION(WEBKIT2)
-set_target_properties(WebKit2 PROPERTIES VERSION ${WEBKIT2_VERSION} SOVERSION ${WEBKIT2_VERSION_MAJOR})
+if (NOT PORT STREQUAL "Mac")
+ POPULATE_LIBRARY_VERSION(WEBKIT2)
+ set_target_properties(WebKit2 PROPERTIES VERSION ${WEBKIT2_VERSION} SOVERSION ${WEBKIT2_VERSION_MAJOR})
-if (NOT APPLE)
install(TARGETS WebProcess NetworkProcess DESTINATION "${LIBEXEC_INSTALL_DIR}")
if (SHARED_CORE OR NOT PORT STREQUAL "Qt")
install(TARGETS WebKit2 DESTINATION "${LIB_INSTALL_DIR}")