aboutsummaryrefslogtreecommitdiffstats
path: root/examples/websockets/qmlwebsocketclient/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-06-24 16:42:40 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-06-24 20:51:43 +0200
commit6c00e510619f2bf9f997c1df5b00f03780d57dd3 (patch)
tree7f9dac7b5b10cdfe1fef505dd8527402ed459825 /examples/websockets/qmlwebsocketclient/CMakeLists.txt
parentf7f36efe0e933b86b88b7f2156bc0d646a3b45ee (diff)
CMake: Regenerate projects
Mostly needed for src/ project, to build websockets without checking for the textcodec feature. Amends aeeaa00fa083ac339d0770d633d22f203c504253 Change-Id: I90cd219294575c763501e47b9025e8a50017641a Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/websockets/qmlwebsocketclient/CMakeLists.txt')
-rw-r--r--examples/websockets/qmlwebsocketclient/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/examples/websockets/qmlwebsocketclient/CMakeLists.txt b/examples/websockets/qmlwebsocketclient/CMakeLists.txt
index eb67d6e..73da980 100644
--- a/examples/websockets/qmlwebsocketclient/CMakeLists.txt
+++ b/examples/websockets/qmlwebsocketclient/CMakeLists.txt
@@ -9,7 +9,11 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-set(INSTALL_EXAMPLEDIR "examples/websockets/qmlwebsocketclient")
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/websockets/qmlwebsocketclient")
find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)