aboutsummaryrefslogtreecommitdiffstats
path: root/examples/websockets/simplechat/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-10-26 17:39:15 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-12-10 18:23:10 +0100
commit297916ecc50fa9b1c3afe7d8c799481d424133c7 (patch)
treebb47ca1f5d8cbfec056ae573acc0ad7ebc71a46a /examples/websockets/simplechat/CMakeLists.txt
parent8c66fb463ce3091015b17ffb1418c574f1ebef85 (diff)
CMake: Regenerate examples to set the WIN32_EXECUTABLE property
As well as the MACOSX_BUNDLE properties as necessary. Task-number: QTBUG-87664 Change-Id: I75fa3596c08b5246a61572f31dc0b6ff1ccb8b2a Reviewed-by: MÃ¥rten Nordheim <marten.nordheim@qt.io>
Diffstat (limited to 'examples/websockets/simplechat/CMakeLists.txt')
-rw-r--r--examples/websockets/simplechat/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/websockets/simplechat/CMakeLists.txt b/examples/websockets/simplechat/CMakeLists.txt
index 6b67fd6..349d70e 100644
--- a/examples/websockets/simplechat/CMakeLists.txt
+++ b/examples/websockets/simplechat/CMakeLists.txt
@@ -21,6 +21,10 @@ qt_add_executable(chatserver
chatserver.cpp chatserver.h
main.cpp
)
+set_target_properties(chatserver PROPERTIES
+ WIN32_EXECUTABLE FALSE
+ MACOSX_BUNDLE FALSE
+)
target_link_libraries(chatserver PUBLIC
Qt::WebSockets
)