aboutsummaryrefslogtreecommitdiffstats
path: root/examples/websockets/simplechat/CMakeLists.txt
diff options
context:
space:
mode:
authorMaurice Kalinowski <maurice.kalinowski@qt.io>2019-09-16 14:22:07 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-09-16 14:47:09 +0000
commita3c87a0e44bb67cc3f726dd915178f9f307480e8 (patch)
tree6b40f1f687dd6e25d71e41c37eed2b230524e83f /examples/websockets/simplechat/CMakeLists.txt
parenta5b0495ac273bcc841298b52dae3ca9bb608edf7 (diff)
Add initial-support for cmake
Task-number: QTBUG-78180 Change-Id: If6cf82c61d605332402feffca9bde2ea0dd6e313 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'examples/websockets/simplechat/CMakeLists.txt')
-rw-r--r--examples/websockets/simplechat/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/examples/websockets/simplechat/CMakeLists.txt b/examples/websockets/simplechat/CMakeLists.txt
new file mode 100644
index 0000000..367913f
--- /dev/null
+++ b/examples/websockets/simplechat/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Generated from simplechat.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(chatserver LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+set(INSTALL_EXAMPLEDIR "examples")
+
+find_package(Qt6 COMPONENTS WebSockets)
+
+add_executable(chatserver
+ chatserver.cpp chatserver.h
+ main.cpp
+)
+target_link_libraries(chatserver PUBLIC
+ Qt::WebSockets
+)
+
+install(TARGETS chatserver
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)