summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAri Parkkila <ari.parkkila@qt.io>2023-03-07 08:46:28 +0200
committerAri Parkkila <ari.parkkila@qt.io>2023-03-10 08:26:24 +0000
commit3b83bf6e5226359cfb29d10bf61b2bcdcac088a3 (patch)
treec0b1cac15a7778fce839112aad321bbb7565d8a4
parent7a79f2331966de78873dccceb37c7d9d3bb1df6a (diff)
Change Renesas R-Car-H3 Starter Kit Premier to boot from SD card
Update U-Boot to start kernel from SD card with r8a77951-ulcb.dtb. Task-number: QTBUG-110929 Change-Id: Id7aa759397adf4a0584d623bd99c39be2ef4aac5 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-bsp/u-boot/u-boot/0001-Change-rcar3_ulcb-to-boot-from-sd-card.patch41
-rw-r--r--recipes-bsp/u-boot/u-boot_%.bbappend33
2 files changed, 74 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot/0001-Change-rcar3_ulcb-to-boot-from-sd-card.patch b/recipes-bsp/u-boot/u-boot/0001-Change-rcar3_ulcb-to-boot-from-sd-card.patch
new file mode 100644
index 0000000..0e9287a
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/0001-Change-rcar3_ulcb-to-boot-from-sd-card.patch
@@ -0,0 +1,41 @@
+From da24b99fa161fc3736f8e62b6ec469c39a06f206 Mon Sep 17 00:00:00 2001
+From: Ari Parkkila <ari.parkkila@qt.io>
+Date: Mon, 6 Mar 2023 14:07:17 +0200
+Subject: [PATCH] Change rcar3_ulcb to boot from sd card
+
+---
+ configs/rcar3_ulcb_defconfig | 4 ++--
+ include/configs/rcar-gen3-common.h | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/configs/rcar3_ulcb_defconfig b/configs/rcar3_ulcb_defconfig
+index 97fae236dc..b4f996c5cf 100644
+--- a/configs/rcar3_ulcb_defconfig
++++ b/configs/rcar3_ulcb_defconfig
+@@ -13,9 +13,9 @@ CONFIG_DEFAULT_DEVICE_TREE="r8a77950-ulcb-u-boot"
+ CONFIG_SMBIOS_PRODUCT_NAME=""
+ CONFIG_FIT=y
+ CONFIG_USE_BOOTARGS=y
+-CONFIG_BOOTARGS="root=/dev/nfs rw nfsroot=192.168.0.1:/export/rfs ip=192.168.0.20"
++CONFIG_BOOTARGS="rw root=/dev/mmcblk1p2 rootwait"
+ CONFIG_SUPPORT_RAW_INITRD=y
+-CONFIG_DEFAULT_FDT_FILE="r8a77950-ulcb.dtb"
++CONFIG_DEFAULT_FDT_FILE="r8a77951-ulcb.dtb"
+ CONFIG_VERSION_VARIABLE=y
+ CONFIG_HUSH_PARSER=y
+ CONFIG_CMD_BOOTZ=y
+diff --git a/include/configs/rcar-gen3-common.h b/include/configs/rcar-gen3-common.h
+index 21b8f858cc..1634ecc89b 100644
+--- a/include/configs/rcar-gen3-common.h
++++ b/include/configs/rcar-gen3-common.h
+@@ -63,8 +63,8 @@
+ "bootm_size=0x10000000\0"
+
+ #define CONFIG_BOOTCOMMAND \
+- "tftp 0x48080000 Image; " \
+- "tftp 0x48000000 Image-"CONFIG_DEFAULT_FDT_FILE"; " \
++ "fatload mmc 0:1 0x48080000 Image; " \
++ "fatload mmc 0:1 0x48000000 "CONFIG_DEFAULT_FDT_FILE"; " \
+ "booti 0x48080000 - 0x48000000"
+
+ /* SPL support */
diff --git a/recipes-bsp/u-boot/u-boot_%.bbappend b/recipes-bsp/u-boot/u-boot_%.bbappend
new file mode 100644
index 0000000..84d0af6
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_%.bbappend
@@ -0,0 +1,33 @@
+############################################################################
+##
+## Copyright (C) 2023 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI:append:h3ulcb = "\
+ file://0001-Change-rcar3_ulcb-to-boot-from-sd-card.patch \
+"