summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-01-04 14:51:39 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2019-01-07 15:08:21 +0000
commit86239a5a43e8d7892a706a094016e9f94fdb68c9 (patch)
tree83385fb10dda05b02f54c166ae514e791f6c352a
parent081f74375ecfad257fca293353ff5c68924baf52 (diff)
draak: fix linux-libc-header do_install step
Override install step and remove header that does not exist in the draak's version of the linux-libc-headers. Fix "oe_multilib_header: Unable to find header asm/bpf_perf_event.h." Change-Id: I3a4f08a8e7ad9683b39c3cb5db014446e4c069a1 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_%.bbappend34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/linux-libc-headers/linux-libc-headers_%.bbappend b/recipes/linux-libc-headers/linux-libc-headers_%.bbappend
new file mode 100644
index 0000000..e1022d8
--- /dev/null
+++ b/recipes/linux-libc-headers/linux-libc-headers_%.bbappend
@@ -0,0 +1,34 @@
+############################################################################
+##
+## Copyright (C) 2018 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+# override to remove asm/bpf_perf_event.h
+do_install_armmultilib_draak () {
+ oe_multilib_header asm/auxvec.h asm/bitsperlong.h asm/byteorder.h asm/fcntl.h asm/hwcap.h asm/ioctls.h asm/kvm.h asm/kvm_para.h asm/mman.h asm/param.h asm/perf_regs.h
+ oe_multilib_header asm/posix_types.h asm/ptrace.h asm/setup.h asm/sigcontext.h asm/siginfo.h asm/signal.h asm/stat.h asm/statfs.h asm/swab.h asm/types.h asm/unistd.h
+}