aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2021-03-18 13:49:42 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-03-18 14:02:01 +0000
commit0844eaab842c280754551e56ae356bf13b314043 (patch)
treeb3cabe6b5c68dfe6791fa2c2c0441321b70f4f16
parent6fb9bc9eecb149f654a2d415412a7c8fb4fdbf29 (diff)
gdb: add needed libraries for debugger on Windows SDK
The gdb needs more libraries that are available in the bin directory. Add symlinks to those libraries, so that they are available without need to modify PATH. Change-Id: I4f8fd6761cad484819a820dbb8fe16768c5499d5 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit c9ee7457ec7c1a27268fc392191cc0001b5a92de) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend b/meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend
index 9f169ca1..4d77c947 100644
--- a/meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend
+++ b/meta-boot2qt-distro/recipes-devtools/gdb/gdb-cross-canadian_%.bbappend
@@ -54,4 +54,8 @@ do_install_append_sdkmingw32() {
ln -s ../python35.dll ${D}${bindir}/
ln -s ../python35.zip ${D}${bindir}/
ln -s ../libgcc_s_seh-1.dll ${D}${bindir}/
+ ln -s ../libexpat.dll ${D}${bindir}/
+ ln -s ../libiconv-2.dll ${D}${bindir}/
+ ln -s ../libintl-8.dll ${D}${bindir}/
+ ln -s ../libstdc++-6.dll ${D}${bindir}/
}