aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2021-03-25 10:14:49 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-03-26 15:33:56 +0000
commit3f86afed9ea4ac7f274c3ef30b90d426cfea7659 (patch)
treefa2de9e11a8c4a5f2e0196d44c2fa5fd6813cf4a
parentf9b5de95379bc075ddf28308c792d9f10043140f (diff)
Include all addons into the image
Restructure the packagegroup recipe used for the sdk and images. Remove target packagegroups and use the same ones for image and sdk. Remove all automation recipes, those addons are now in the embedded sdk and image. Change-Id: I5149cedc80ad500782c419b32fa33679d9c5f3e7 Reviewed-by: Pasi Petäjäjärvi <pasi.petajajarvi@qt.io> (cherry picked from commit 3706c35f8003e63d52aa1f6e5d38c2eab3717bfe) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-toolchain-target.bb (renamed from meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt6-toolchain-target.bb)15
-rw-r--r--meta-boot2qt-distro/recipes-qt/images/b2qt-automation-qt6-image.bb55
-rw-r--r--meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-qt6-image.bb2
-rw-r--r--meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automation-qbsp.bb50
-rw-r--r--meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-automation-qt6-sdk.bb39
-rw-r--r--meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt6-sdk.bb5
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-addons.bb40
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb4
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt6-toolchain-target.bb63
-rw-r--r--meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt6-modules.bb53
10 files changed, 19 insertions, 307 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt6-toolchain-target.bb b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-toolchain-target.bb
index 6cfb624b..ea82e864 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-qt6-toolchain-target.bb
+++ b/meta-boot2qt-distro/recipes-core/packagegroups/packagegroup-b2qt-embedded-toolchain-target.bb
@@ -1,6 +1,6 @@
############################################################################
##
-## Copyright (C) 2020 The Qt Company Ltd.
+## Copyright (C) 2021 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -27,7 +27,7 @@
##
############################################################################
-DESCRIPTION = "Target packages for B2Qt Automation Qt6 SDK"
+DESCRIPTION = "Target packages for B2Qt embedded SDK"
LICENSE = "The-Qt-Company-Commercial"
PR = "r0"
@@ -35,7 +35,14 @@ inherit packagegroup
PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
+MACHINE_EXTRA_INSTALL_SDK ?= ""
+
+GCC-SANITIZERS ?= "gcc-sanitizers"
+GCC-SANITIZERS_mipsarch = ""
+GCC-SANITIZERS_libc-musl = ""
+
RDEPENDS_${PN} += " \
- qtmqtt-dev \
- qtopcua-dev \
+ packagegroup-core-standalone-sdk-target \
+ ${GCC-SANITIZERS} \
+ ${MACHINE_EXTRA_INSTALL_SDK} \
"
diff --git a/meta-boot2qt-distro/recipes-qt/images/b2qt-automation-qt6-image.bb b/meta-boot2qt-distro/recipes-qt/images/b2qt-automation-qt6-image.bb
deleted file mode 100644
index 268355e1..00000000
--- a/meta-boot2qt-distro/recipes-qt/images/b2qt-automation-qt6-image.bb
+++ /dev/null
@@ -1,55 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2020 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-DESCRIPTION = "B2Qt Automation Qt6 image"
-LICENSE = "The-Qt-Company-Commercial"
-LIC_FILES_CHKSUM = "file://${BOOT2QTBASE}/licenses/The-Qt-Company-Commercial;md5=213dc233cc25f71b1447fbe95ec90adf"
-
-DEPLOY_CONF_TYPE = "Qt for Automation ($QT_VERSION)"
-
-IMAGE_FEATURES += "\
- package-management \
- ssh-server-dropbear \
- tools-debug \
- tools-profile \
- debug-tweaks \
- hwcodecs \
- "
-
-inherit core-image qbsp-image
-inherit consistent_timestamps
-
-IMAGE_INSTALL += "\
- packagegroup-b2qt-embedded-base \
- packagegroup-b2qt-embedded-tools \
- ${@bb.utils.contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
- packagegroup-b2qt-qt6-modules \
- packagegroup-b2qt-embedded-addons \
- packagegroup-b2qt-automation-addons \
- "
diff --git a/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-qt6-image.bb b/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-qt6-image.bb
index bffbc9e4..4ba2dd0f 100644
--- a/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-qt6-image.bb
+++ b/meta-boot2qt-distro/recipes-qt/images/b2qt-embedded-qt6-image.bb
@@ -49,6 +49,6 @@ IMAGE_INSTALL += "\
packagegroup-b2qt-embedded-base \
packagegroup-b2qt-embedded-tools \
${@bb.utils.contains("DISTRO_FEATURES", "gstreamer", "packagegroup-b2qt-embedded-gstreamer", "", d)} \
- packagegroup-b2qt-qt6-modules \
+ packagegroup-qt6-modules \
packagegroup-b2qt-embedded-addons \
"
diff --git a/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automation-qbsp.bb b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automation-qbsp.bb
deleted file mode 100644
index 51fe90b8..00000000
--- a/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-automation-qbsp.bb
+++ /dev/null
@@ -1,50 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2018 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-DESCRIPTION = "Meta task for QBSP creation"
-
-LICENSE = "The-Qt-Company-Commercial"
-LIC_FILES_CHKSUM = "file://${BOOT2QTBASE}/licenses/The-Qt-Company-Commercial;md5=213dc233cc25f71b1447fbe95ec90adf"
-
-# get Qt version number
-require recipes-qt/qt6/qt6-git.inc
-S = "${WORKDIR}"
-
-inherit qbsp
-
-PV := "${@d.getVar('PV').split('+')[0]}"
-
-VERSION_SHORT = "${@d.getVar('PV').replace('.','')}"
-QBSP_NAME = "Automation ${PV}"
-QBSP_MACHINE = "${@d.getVar('MACHINE').replace('-','')}"
-QBSP_INSTALLER_COMPONENT = "automation.${VERSION_SHORT}.${QBSP_MACHINE}"
-QBSP_INSTALL_PATH = "/${PV}/Automation/${MACHINE}"
-
-QBSP_SDK_TASK = "meta-toolchain-b2qt-automation-qt6-sdk"
-QBSP_IMAGE_TASK = "b2qt-automation-qt6-image"
diff --git a/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-automation-qt6-sdk.bb b/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-automation-qt6-sdk.bb
deleted file mode 100644
index dbf75147..00000000
--- a/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-automation-qt6-sdk.bb
+++ /dev/null
@@ -1,39 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2018 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-DESCRIPTION = "B2Qt embedded Qt6 SDK toolchain"
-
-LICENSE = "The-Qt-Company-Commercial"
-LIC_FILES_CHKSUM = "file://${BOOT2QTBASE}/licenses/The-Qt-Company-Commercial;md5=213dc233cc25f71b1447fbe95ec90adf"
-
-inherit populate_b2qt_qt6_sdk
-
-TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt6-toolchain-host"
-TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt6-toolchain-target \
- packagegroup-b2qt-automation-qt6-toolchain-target"
diff --git a/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt6-sdk.bb b/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt6-sdk.bb
index 5c274f78..8112f329 100644
--- a/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt6-sdk.bb
+++ b/meta-boot2qt-distro/recipes-qt/meta/meta-toolchain-b2qt-embedded-qt6-sdk.bb
@@ -35,4 +35,7 @@ LIC_FILES_CHKSUM = "file://${BOOT2QTBASE}/licenses/The-Qt-Company-Commercial;md5
inherit populate_b2qt_qt6_sdk
TOOLCHAIN_HOST_TASK += "nativesdk-packagegroup-b2qt-embedded-qt6-toolchain-host"
-TOOLCHAIN_TARGET_TASK += "packagegroup-b2qt-embedded-qt6-toolchain-target"
+TOOLCHAIN_TARGET_TASK += "\
+ packagegroup-b2qt-embedded-toolchain-target \
+ packagegroup-qt6-modules \
+"
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-addons.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-addons.bb
deleted file mode 100644
index e35243d8..00000000
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-automation-addons.bb
+++ /dev/null
@@ -1,40 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2018 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-DESCRIPTION = "Automation specific Qt packages"
-LICENSE = "The-Qt-Company-Commercial"
-
-inherit packagegroup
-
-PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
-
-RDEPENDS_${PN} += " \
- qtmqtt \
- qtopcua \
- "
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
index b3aae7ca..9364f007 100644
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
+++ b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-addons.bb
@@ -1,6 +1,6 @@
############################################################################
##
-## Copyright (C) 2016 The Qt Company Ltd.
+## Copyright (C) 2021 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -38,4 +38,6 @@ RDEPENDS_${PN} += " \
boot2qt-appcontroller \
boot2qt-startupscreen \
qdb \
+ qtdeclarative-tools \
+ qttools-tools \
"
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt6-toolchain-target.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt6-toolchain-target.bb
deleted file mode 100644
index 1373c3b9..00000000
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-embedded-qt6-toolchain-target.bb
+++ /dev/null
@@ -1,63 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2020 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-DESCRIPTION = "Target packages for B2Qt embedded Qt6 SDK"
-LICENSE = "The-Qt-Company-Commercial"
-PR = "r0"
-
-inherit packagegroup
-
-PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
-
-MACHINE_EXTRA_INSTALL_SDK ?= ""
-
-GCC-SANITIZERS ?= "gcc-sanitizers"
-GCC-SANITIZERS_mipsarch = ""
-GCC-SANITIZERS_libc-musl = ""
-
-RDEPENDS_${PN} += " \
- ${MACHINE_EXTRA_INSTALL_SDK} \
- packagegroup-core-standalone-sdk-target \
- ${GCC-SANITIZERS} \
- \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'qt3d-dev', '', d)} \
- qtbase-dev \
- qtbase-staticdev \
- qtdeclarative-dev \
- qtdeclarative-staticdev \
- qtshadertools-dev \
- qtimageformats-dev \
- qtnetworkauth-dev \
- qtquick3d-dev \
- qtquickcontrols2-dev \
- qtquicktimeline-dev \
- qtsvg-dev \
- qttools-dev \
- ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'qtwayland-dev', '', d)} \
- "
diff --git a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt6-modules.bb b/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt6-modules.bb
deleted file mode 100644
index 99c00b57..00000000
--- a/meta-boot2qt-distro/recipes-qt/packagegroups/packagegroup-b2qt-qt6-modules.bb
+++ /dev/null
@@ -1,53 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2020 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-DESCRIPTION = "Qt6 modules"
-LICENSE = "The-Qt-Company-Commercial"
-
-inherit packagegroup
-
-PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
-
-RDEPENDS_${PN} += " \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'qt3d', '', d)} \
- qtbase \
- qtdeclarative \
- qtdeclarative-tools \
- qtimageformats \
- qtnetworkauth \
- qtquick3d \
- qtquickcontrols2 \
- qtquicktimeline \
- qtsvg \
- qttools \
- qttools-tools \
- qttranslations-qtbase \
- qttranslations-qtdeclarative \
- ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'qtwayland', '', d)} \
- "