aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2021-03-04 08:55:49 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-03-04 16:10:43 +0000
commit8a292b0dd27eda42d21b7c172b01a14d3e7bcf5c (patch)
tree431c481fd89a056f87beddf561725843e84dbba7
parentdadd37dcef42f8750f1d54fa0cfa5f087b81ea93 (diff)
imx8: set default dri device to kms config
On iMX8, there are two dri devices available and the first one is not always the one that is usable for Qt. Add kms config to select the appropriate dri device: card0 on NXP boards and card1 on Toradex boards. Change-Id: Ic0e13494e15db35618801870489818d5d776878c Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit 42af4b0b5638e3a24663a95df3fce9652ec6d479) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-qt/boot2qt-addons/default-qt-envs.bbappend4
-rw-r--r--meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-qt/boot2qt-addons/default-qt-envs/mx8/kms.conf4
-rw-r--r--meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-qt/boot2qt-addons/default-qt-envs.bbappend30
-rw-r--r--meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-qt/boot2qt-addons/default-qt-envs/mx8/kms.conf4
4 files changed, 41 insertions, 1 deletions
diff --git a/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-qt/boot2qt-addons/default-qt-envs.bbappend b/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
index 68c833f5..d31eb5b4 100644
--- a/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
+++ b/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
@@ -1,6 +1,6 @@
############################################################################
##
-## Copyright (C) 2019 The Qt Company Ltd.
+## Copyright (C) 2021 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -27,6 +27,8 @@
##
############################################################################
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
SRC_URI_append_mx8 = " file://kms.conf"
do_configure_append() {
diff --git a/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-qt/boot2qt-addons/default-qt-envs/mx8/kms.conf b/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-qt/boot2qt-addons/default-qt-envs/mx8/kms.conf
new file mode 100644
index 00000000..416a053e
--- /dev/null
+++ b/meta-boot2qt-distro/dynamic-layers/freescale-layer/recipes-qt/boot2qt-addons/default-qt-envs/mx8/kms.conf
@@ -0,0 +1,4 @@
+{
+ "hwcursor": false,
+ "device": "/dev/dri/card0"
+}
diff --git a/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-qt/boot2qt-addons/default-qt-envs.bbappend b/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
new file mode 100644
index 00000000..419b167c
--- /dev/null
+++ b/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-qt/boot2qt-addons/default-qt-envs.bbappend
@@ -0,0 +1,30 @@
+############################################################################
+##
+## Copyright (C) 2021 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-qt/boot2qt-addons/default-qt-envs/mx8/kms.conf b/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-qt/boot2qt-addons/default-qt-envs/mx8/kms.conf
new file mode 100644
index 00000000..19a208c0
--- /dev/null
+++ b/meta-boot2qt-distro/dynamic-layers/toradex-nxp-layer/recipes-qt/boot2qt-addons/default-qt-envs/mx8/kms.conf
@@ -0,0 +1,4 @@
+{
+ "hwcursor": false,
+ "device": "/dev/dri/card1"
+}