aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2021-04-06 11:21:54 +0300
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-04-06 10:40:29 +0000
commitaa4f3234dda5f9d152541ab8e43341e6a29998c7 (patch)
treef611f1a5a318f3f87db1e3e77cc5a343d4897816
parent3f86afed9ea4ac7f274c3ef30b90d426cfea7659 (diff)
cmake: remove upstreamed changes
The update cmake toolchain file is now merged in upstream poky. Change-Id: I0fb65b57ce027af208fed18e11403e170b24f197 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit 19b13f1e458b67839d1fb796b9facc2031925e6a) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--meta-boot2qt-distro/recipes-devtools/cmake/cmake/OEToolchainConfig.cmake25
-rw-r--r--meta-boot2qt-distro/recipes-devtools/cmake/cmake_%.bbappend30
2 files changed, 0 insertions, 55 deletions
diff --git a/meta-boot2qt-distro/recipes-devtools/cmake/cmake/OEToolchainConfig.cmake b/meta-boot2qt-distro/recipes-devtools/cmake/cmake/OEToolchainConfig.cmake
deleted file mode 100644
index 8f6f3a27..00000000
--- a/meta-boot2qt-distro/recipes-devtools/cmake/cmake/OEToolchainConfig.cmake
+++ /dev/null
@@ -1,25 +0,0 @@
-set( CMAKE_SYSTEM_NAME Linux )
-set( CMAKE_C_FLAGS $ENV{CFLAGS} CACHE STRING "" FORCE )
-set( CMAKE_CXX_FLAGS $ENV{CXXFLAGS} CACHE STRING "" FORCE )
-set( CMAKE_ASM_FLAGS ${CMAKE_C_FLAGS} CACHE STRING "" FORCE )
-set( CMAKE_LDFLAGS_FLAGS ${CMAKE_CXX_FLAGS} CACHE STRING "" FORCE )
-set( CMAKE_SYSROOT $ENV{OECORE_TARGET_SYSROOT} )
-
-set( CMAKE_FIND_ROOT_PATH $ENV{OECORE_TARGET_SYSROOT} )
-set( CMAKE_FIND_ROOT_PATH_MODE_PROGRAM NEVER )
-set( CMAKE_FIND_ROOT_PATH_MODE_LIBRARY ONLY )
-set( CMAKE_FIND_ROOT_PATH_MODE_INCLUDE ONLY )
-set( CMAKE_FIND_ROOT_PATH_MODE_PACKAGE ONLY )
-
-set(CMAKE_FIND_LIBRARY_CUSTOM_LIB_SUFFIX "$ENV{OE_CMAKE_FIND_LIBRARY_CUSTOM_LIB_SUFFIX}")
-
-# Set CMAKE_SYSTEM_PROCESSOR from the sysroot name (assuming processor-distro-os).
-if ($ENV{SDKTARGETSYSROOT} MATCHES "/sysroots/([a-zA-Z0-9_-]+)-.+-.+")
- set(CMAKE_SYSTEM_PROCESSOR ${CMAKE_MATCH_1})
-endif()
-
-# Include the toolchain configuration subscripts
-file( GLOB toolchain_config_files "${CMAKE_CURRENT_LIST_FILE}.d/*.cmake" )
-foreach(config ${toolchain_config_files})
- include(${config})
-endforeach()
diff --git a/meta-boot2qt-distro/recipes-devtools/cmake/cmake_%.bbappend b/meta-boot2qt-distro/recipes-devtools/cmake/cmake_%.bbappend
deleted file mode 100644
index ca484d5b..00000000
--- a/meta-boot2qt-distro/recipes-devtools/cmake/cmake_%.bbappend
+++ /dev/null
@@ -1,30 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2020 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"