aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2021-11-22 19:29:17 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-11-22 20:31:29 +0000
commit6cc0596766ab593c77e3d9853b6e803118c52f32 (patch)
treec37406d6266406c32e7b77cbbd564cf9e8d29baf
parent93a5e61abea41a56877d044d46906dd542f8fd91 (diff)
qtbase: add workaround for mingw 7.0
QtBase now forces WINVER and friends to higher version than mingw 7.0 is able to support. Add workround to lower the NTDDI_VERSION to disable TLS 1.3 support in schannel and fix compilation error: src/plugins/tls/schannel/qtls_schannel.cpp:856:5: error: 'TLS_PARAMETERS' was not declared in this scope; did you mean 'VIDEOPARAMETERS'? | 856 | TLS_PARAMETERS tlsParameters = { | | ^~~~~~~~~~~~~~ Change-Id: I8fb1ca951510c2441b8aef830a284416539fb65d Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit 0c1895aa5424b99edaf6bd49f5a4ad05551b0d24) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--meta-boot2qt-distro/recipes-qt/qt6/qtbase_git.bbappend2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/qt6/qtbase_git.bbappend b/meta-boot2qt-distro/recipes-qt/qt6/qtbase_git.bbappend
index 8c9a5396..d75f66f2 100644
--- a/meta-boot2qt-distro/recipes-qt/qt6/qtbase_git.bbappend
+++ b/meta-boot2qt-distro/recipes-qt/qt6/qtbase_git.bbappend
@@ -40,3 +40,5 @@ do_configure:prepend() {
}
EXTRA_OECMAKE:remove = "-DQT_AVOID_CMAKE_ARCHIVING_API=ON"
+
+BUILDSDK_CFLAGS:append:mingw32 = " -DNTDDI_VERSION=0x06010000"