aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2021-09-21 08:13:22 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2021-09-22 09:49:21 +0300
commitf4d2c4146aeba4110aa55c568f935ccf5f75012c (patch)
tree1a920f38f5b42ee7bbed57740dba37b2e635ec64
parent9d1b9f32522de7d2ea12138104d89125b390132c (diff)
intel: fix mediasdk build with gold linker
Remove linker option that's not supported by gold linker: libexec/x86_64-poky-linux/gcc/x86_64-poky-linux/10.2.0/ld: --default-symver: unknown option Change-Id: Ibd580eebb1c08395cec472de508165929e5bfe99 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/dynamic-layers/intel/recipes-multimedia/mediasdk/intel-mediasdk/0001-fix-build-with-gold-linker.patch22
-rw-r--r--meta-boot2qt-distro/dynamic-layers/intel/recipes-multimedia/mediasdk/intel-mediasdk_%.bbappend32
2 files changed, 54 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/dynamic-layers/intel/recipes-multimedia/mediasdk/intel-mediasdk/0001-fix-build-with-gold-linker.patch b/meta-boot2qt-distro/dynamic-layers/intel/recipes-multimedia/mediasdk/intel-mediasdk/0001-fix-build-with-gold-linker.patch
new file mode 100644
index 00000000..ff240d8f
--- /dev/null
+++ b/meta-boot2qt-distro/dynamic-layers/intel/recipes-multimedia/mediasdk/intel-mediasdk/0001-fix-build-with-gold-linker.patch
@@ -0,0 +1,22 @@
+From c0f3c4da036810edc4b9fc43316156b55f7b3c18 Mon Sep 17 00:00:00 2001
+From: Samuli Piippo <samuli.piippo@qt.io>
+Date: Mon, 20 Sep 2021 06:44:02 +0000
+Subject: [PATCH] fix build with gold linker
+
+---
+ builder/FindPackages.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/builder/FindPackages.cmake b/builder/FindPackages.cmake
+index 1cd93122..0081d132 100644
+--- a/builder/FindPackages.cmake
++++ b/builder/FindPackages.cmake
+@@ -151,7 +151,7 @@ function(configure_libmfx_target target)
+ endif()
+
+ set(SCOPE_CFLAGS ${SCOPE_CFLAGS} PARENT_SCOPE)
+- set(SCOPE_LINKFLAGS "${SCOPE_LINKFLAGS} -Wl,--default-symver" PARENT_SCOPE)
++ # set(SCOPE_LINKFLAGS "${SCOPE_LINKFLAGS} -Wl,--default-symver" PARENT_SCOPE)
+ set(SCOPE_LIBS ${SCOPE_LIBS} mfx PARENT_SCOPE)
+ endfunction()
+
diff --git a/meta-boot2qt-distro/dynamic-layers/intel/recipes-multimedia/mediasdk/intel-mediasdk_%.bbappend b/meta-boot2qt-distro/dynamic-layers/intel/recipes-multimedia/mediasdk/intel-mediasdk_%.bbappend
new file mode 100644
index 00000000..1ab33178
--- /dev/null
+++ b/meta-boot2qt-distro/dynamic-layers/intel/recipes-multimedia/mediasdk/intel-mediasdk_%.bbappend
@@ -0,0 +1,32 @@
+############################################################################
+##
+## Copyright (C) 2021 The Qt Company Ltd.
+## Contact: https://www.qt.io/licensing/
+##
+## This file is part of the Boot to Qt meta layer.
+##
+## $QT_BEGIN_LICENSE:GPL$
+## Commercial License Usage
+## Licensees holding valid commercial Qt licenses may use this file in
+## accordance with the commercial license agreement provided with the
+## Software or, alternatively, in accordance with the terms contained in
+## a written agreement between you and The Qt Company. For licensing terms
+## and conditions see https://www.qt.io/terms-conditions. For further
+## information use the contact form at https://www.qt.io/contact-us.
+##
+## GNU General Public License Usage
+## Alternatively, this file may be used under the terms of the GNU
+## General Public License version 3 or (at your option) any later version
+## approved by the KDE Free Qt Foundation. The licenses are as published by
+## the Free Software Foundation and appearing in the file LICENSE.GPL3
+## included in the packaging of this file. Please review the following
+## information to ensure the GNU General Public License requirements will
+## be met: https://www.gnu.org/licenses/gpl-3.0.html.
+##
+## $QT_END_LICENSE$
+##
+############################################################################
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://0001-fix-build-with-gold-linker.patch"