aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-05-03 08:59:27 +0000
committerSamuli Piippo <samuli.piippo@qt.io>2022-05-03 16:40:54 +0000
commit4004e894172704ab4bc79efbb077aeea8972933d (patch)
tree6a019c7c159fa729920771238ec19bcd2fae0799
parentf650e73cc8b38465346b0b640d55366872e58408 (diff)
rpi: use config fragments for rpi kernel
Raspberrypi kernel recipes has been converted to use config fragments. Pick-to: 6.3 6.2 Change-Id: Id535a4ef17dd7ab8a4d4e7c05ed710fd3d835dd3 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi/boot2qt.cfg1
-rw-r--r--meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend8
2 files changed, 5 insertions, 4 deletions
diff --git a/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi/boot2qt.cfg b/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi/boot2qt.cfg
new file mode 100644
index 00000000..81f7be96
--- /dev/null
+++ b/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi/boot2qt.cfg
@@ -0,0 +1 @@
+CONFIG_UPROBE_EVENTS=y
diff --git a/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend b/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
index 24a31deb..5b50e45f 100644
--- a/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
+++ b/meta-boot2qt-distro/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
@@ -1,6 +1,6 @@
############################################################################
##
-## Copyright (C) 2018 The Qt Company Ltd.
+## Copyright (C) 2022 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
@@ -27,6 +27,6 @@
##
############################################################################
-do_configure:prepend() {
- echo "CONFIG_UPROBE_EVENTS=y" >> ${WORKDIR}/defconfig
-}
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://boot2qt.cfg"