aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-05-13 10:37:44 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2022-05-13 13:14:16 +0300
commitf1992059e06f7b53bf41b94512ff9f967f3b38fc (patch)
tree05f89a47ad5556008899e17d1a221ef7ae3ac263
parentb81168e7556363e05d344a586d0096c97ed943fb (diff)
qbsp: use dev as component version
... if we are using Qt from the dev branch. This makes the installer dependencies work correctly. Fixes: QTBUG-103451 Change-Id: I663f6199f4f5b30964cdb27476769b9b88582161 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb
index b5afe33b..8c6b78a1 100644
--- a/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb
+++ b/meta-boot2qt-distro/recipes-qt/meta/meta-b2qt-embedded-qbsp.bb
@@ -40,7 +40,7 @@ inherit qbsp
PV := "${@d.getVar('PV').split('+')[0]}"
-VERSION_SHORT = "${@d.getVar('PV').replace('.','')}"
+VERSION_SHORT = "${@d.getVar('PV').replace('.','') if d.getVar('QT_MODULE_BRANCH') != 'dev' else 'dev'}"
QBSP_NAME = "Boot2Qt ${PV}"
QBSP_MACHINE = "${@d.getVar('MACHINE').replace('-','')}"
QBSP_INSTALLER_COMPONENT = "embedded.b2qt.${VERSION_SHORT}.${QBSP_MACHINE}"