aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2023-01-24 06:20:52 +0000
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-01-31 08:31:55 +0000
commit995036c8dd8db987cb5ff5e2852bf6e13871519a (patch)
treeb8ccf78b7878825f44fa1f55451f2a4a9ebed0ac
parent8ac7bcf5a9d175db43a2bcf9e8be332b545ffb3b (diff)
meta: use QT_VERSION to mask bbappends
meta-qt6 provides QT_VERSION variable that can be used to identify and then mask bbappends that are not suitable for older Qt versions. This makes it possible to easily switch the meta-qt6 layer to a different version and still keep all the bbappends in the layer. Change-Id: I04091752cf5388e19afd4f78ec6e132155563ba9 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit 2a6f3786391e001a47b458ed5737deea167a027e) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--meta-boot2qt-distro/conf/layer.conf2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/conf/layer.conf b/meta-boot2qt-distro/conf/layer.conf
index e2232c5f..e74ae57c 100644
--- a/meta-boot2qt-distro/conf/layer.conf
+++ b/meta-boot2qt-distro/conf/layer.conf
@@ -55,3 +55,5 @@ BBFILES_DYNAMIC += " \
toradex-nxp-layer:${LAYERDIR}/dynamic-layers/toradex-nxp-layer/recipes*/*/*.bbappend \
"
+BBMASK += "${@ 'qtspeech_git.bbappend' if bb.utils.vercmp_string(d.getVar('QT_VERSION', True), '6.4') < 0 else '' }"
+BBMASK += "${@ 'qtvncserver_git.bbappend' if bb.utils.vercmp_string(d.getVar('QT_VERSION', True), '6.5') < 0 else '' }"