aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2022-12-30 06:37:11 +0000
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-01-04 05:55:12 +0000
commit3170c033f585ed4064bc15ad4e9fa43fdc524f73 (patch)
tree9441561e00f42b1be3a41ec6fba6e4eaf779d124
parente0dd47b0b7ceab33b2f5f2db68e2aad97b0f4115 (diff)
mingw: remove unneeded cmake patch
Revert 6b0c6684b57586b346b92fb70eb9e2582705f180 since fix is no longer needed for mingw build. Change-Id: Ia4a43beebd962795b18a48084dc5d0c689cfd0f2 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit b5a3b5abe6d21fe71c040e026a3a2c60ebeef451) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--meta-boot2qt-distro/recipes-devtools/cmake/cmake/0001-Fix-build-for-mingw32.patch25
-rw-r--r--meta-boot2qt-distro/recipes-devtools/cmake/cmake_%.bbappend33
2 files changed, 0 insertions, 58 deletions
diff --git a/meta-boot2qt-distro/recipes-devtools/cmake/cmake/0001-Fix-build-for-mingw32.patch b/meta-boot2qt-distro/recipes-devtools/cmake/cmake/0001-Fix-build-for-mingw32.patch
deleted file mode 100644
index 29005493..00000000
--- a/meta-boot2qt-distro/recipes-devtools/cmake/cmake/0001-Fix-build-for-mingw32.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 969f188d6c1e4697af2344c7398fbfc8c5bc8369 Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Fri, 27 Aug 2021 09:59:24 +0300
-Subject: [PATCH] Fix build for mingw32
-
-SystemTools.cxx:3091:13: error: 'SYMBOLIC_LINK_FLAG_DIRECTORY' was not declared in this scope
----
- Source/kwsys/CMakeLists.txt | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/Source/kwsys/CMakeLists.txt b/Source/kwsys/CMakeLists.txt
-index 7da5971..634401a 100644
---- a/Source/kwsys/CMakeLists.txt
-+++ b/Source/kwsys/CMakeLists.txt
-@@ -927,6 +927,10 @@ if(MSVC OR (WIN32 AND (CMAKE_C_COMPILER_ID STREQUAL "Intel" OR
- )
- endif()
-
-+if(WIN32)
-+ add_definitions(-D_WIN32_LEAN_AND_MEAN -D_WIN32_WINNT=0x0600)
-+endif()
-+
- if(WIN32)
- # Help enforce the use of wide Windows apis.
- add_definitions(-DUNICODE -D_UNICODE)
diff --git a/meta-boot2qt-distro/recipes-devtools/cmake/cmake_%.bbappend b/meta-boot2qt-distro/recipes-devtools/cmake/cmake_%.bbappend
deleted file mode 100644
index 54a2eaf0..00000000
--- a/meta-boot2qt-distro/recipes-devtools/cmake/cmake_%.bbappend
+++ /dev/null
@@ -1,33 +0,0 @@
-############################################################################
-##
-## Copyright (C) 2021 The Qt Company Ltd.
-## Contact: https://www.qt.io/licensing/
-##
-## This file is part of the Boot to Qt meta layer.
-##
-## $QT_BEGIN_LICENSE:GPL$
-## Commercial License Usage
-## Licensees holding valid commercial Qt licenses may use this file in
-## accordance with the commercial license agreement provided with the
-## Software or, alternatively, in accordance with the terms contained in
-## a written agreement between you and The Qt Company. For licensing terms
-## and conditions see https://www.qt.io/terms-conditions. For further
-## information use the contact form at https://www.qt.io/contact-us.
-##
-## GNU General Public License Usage
-## Alternatively, this file may be used under the terms of the GNU
-## General Public License version 3 or (at your option) any later version
-## approved by the KDE Free Qt Foundation. The licenses are as published by
-## the Free Software Foundation and appearing in the file LICENSE.GPL3
-## included in the packaging of this file. Please review the following
-## information to ensure the GNU General Public License requirements will
-## be met: https://www.gnu.org/licenses/gpl-3.0.html.
-##
-## $QT_END_LICENSE$
-##
-############################################################################
-
-FILESEXTRAPATHS:append:mingw32 := "${THISDIR}/${PN}:"
-SRC_URI:append:mingw32 = " \
- file://0001-Fix-build-for-mingw32.patch \
-"