aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2023-01-24 06:20:52 +0000
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-01-31 08:31:55 +0000
commit528e244c3425e65cf5d8e9b301a83d33c23e2c71 (patch)
treeafbf8d1b9fe9c961065b85934c0af810394c36dc
parent4d3eba55366283cb5d70958109ce546ef8c310de (diff)
meta: use QT_VERSION to mask bbappends
meta-qt6 provides QT_VERSION variable that can be used to identify and then mask bbappends that are not suitable for older Qt versions. This makes it possible to easily switch the meta-qt6 layer to a different version and still keep all the bbappends in the layer. Change-Id: I04091752cf5388e19afd4f78ec6e132155563ba9 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> (cherry picked from commit 2a6f3786391e001a47b458ed5737deea167a027e) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
-rw-r--r--meta-boot2qt-distro/conf/layer.conf2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-boot2qt-distro/conf/layer.conf b/meta-boot2qt-distro/conf/layer.conf
index fe0c58b3..fb4007b9 100644
--- a/meta-boot2qt-distro/conf/layer.conf
+++ b/meta-boot2qt-distro/conf/layer.conf
@@ -55,3 +55,5 @@ BBFILES_DYNAMIC += " \
toradex-nxp-layer:${LAYERDIR}/dynamic-layers/toradex-nxp-layer/recipes*/*/*.bbappend \
"
+BBMASK += "${@ 'qtspeech_git.bbappend' if bb.utils.vercmp_string(d.getVar('QT_VERSION', True), '6.4') < 0 else '' }"
+BBMASK += "${@ 'qtvncserver_git.bbappend' if bb.utils.vercmp_string(d.getVar('QT_VERSION', True), '6.5') < 0 else '' }"